UPC 6622: ABS(博弈)

6622: ABS
时间限制: 1 Sec 内存限制: 128 MB
提交: 558 解决: 192
[提交] [状态] [讨论版] [命题人:admin]
题目描述

We have a deck consisting of N cards. Each card has an integer written on it. The integer on the i-th card from the top is ai.
Two people X and Y will play a game using this deck. Initially, X has a card with Z written on it in his hand, and Y has a card with W written on it in his hand. Then, starting from X, they will alternately perform the following action:
Draw some number of cards from the top of the deck. Then, discard the card in his hand and keep the last drawn card instead. Here, at least one card must be drawn.
The game ends when there is no more card in the deck. The score of the game is the absolute difference of the integers written on the cards in the two players’ hand.
X will play the game so that the score will be maximized, and Y will play the game so that the score will be minimized. What will be the score of the game?

Constraints
All input values are integers.
1≤N≤2000
1≤Z,W,ai≤109

输入

Input is given from Standard Input in the following format:
N Z W
a1 a2 … aN

输出

Print the score.

样例输入

3 100 100
10 1000 100

样例输出

900

提示

If X draws two cards first, Y will draw the last card, and the score will be |1000−100|=900.
题意:两个人初始手上分别有Z,W两个牌,一副N个牌在桌面上,每轮取任意>0数目的牌,将手上的牌替换成取得牌最下面那张,然后剩余的扔掉,双方轮流操作直至无牌。!!!结果是两人手上牌的差值K,先手令K尽量大,后手令K尽量小,!!(关键)问结果是什么。

#include<bits/stdc++.h>
#define INF 0x3f3f3f3f
using namespace std;
int main()
{
    int n,z,w;
    cin>>n>>z>>w;
    int num[2005],Max=0,Min=INF;
    for(int i=0;i<n;i++)
    {
        cin>>num[i];
       // Max=max(Max,num[i]);
       // Min=min(Min,num[i]);
    }
    int res=0;
    if(n==1)
        res=abs(num[n-1]-w);
    else
        res=max(abs(num[n-2]-num[n-1]),abs(num[n-1]-w));
    cout<<res<<endl;
    return 0;
}

猜你喜欢

转载自blog.csdn.net/a17865569022/article/details/81486663
UPC
ABS