[JAVA/C++](PAT)1011 WORLD CUP BETTING (20)

版权声明:首发于 www.amoshuang.com https://blog.csdn.net/qq_35499060/article/details/82055781

With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.

Chinese Football Lottery provided a “Triple Winning” game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results — namely W for win, T for tie, and L for lose. There was an odd assigned to each result. The winner’s odd would be the product of the three odds times 65%.

For example, 3 games’ odds are given as the following:

W    T    L

1.1  2.5  1.7

1.2  3.0  1.6

4.1  1.2  1.1

To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.1*3.0*2.5*65%-1)*2 = 37.98 yuans (accurate up to 2 decimal places).

Input

Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to W, T and L.

Output

For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.

Sample Input

1.1 2.5 1.7

1.2 3.0 1.6

4.1 1.2 1.1

Sample Output

T T W 37.98

Java实现

import java.text.DecimalFormat;

import java.util.Scanner;





public class Main {

    public static void main(String[] args){

        Scanner sc = new Scanner(System.in);

        DecimalFormat formatter = new DecimalFormat("#0.00");//小数点后面四舍五入的方式

        Double first[] = new Double[3];

        Double second[] = new Double[3];

        Double third[] = new Double[3];

        String format[] = {"W","T","L"};

        for(int i=0;i<3;i++){

            first[i]= sc.nextDouble();

        }

        for(int i=0;i<3;i++){

            second[i]= sc.nextDouble();

        }

        for(int i=0;i<3;i++){

            third[i]= sc.nextDouble();

        }

        Double firstMax = 0.0;

        Double secondMax = 0.0;

        Double thirdMax = 0.0;

        String firstF="";

        String secondF="";

        String thirdF="";

        for(int i=0;i<3;i++){

            Double x=first[i];

            if(x > firstMax){

                firstMax=x;

                firstF = format[i];

            }

        }

        for(int i=0;i<3;i++){

            Double x=second[i];

            if(x>secondMax){

                secondMax = x;

                secondF = format[i];

            }

        }

        for(int i=0;i<3;i++){

            Double x=third[i];

            if(x>thirdMax){

                thirdMax = x;

                thirdF = format[i];

            }

        }

        //java中double、float不是精准小数,是模拟的,有时候算出来比如是0.0005,会变成0.000499999999

        String total = formatter.format((firstMax*secondMax*thirdMax*0.65-1)*2+0.0000000001);

        String output = firstF+" "+secondF+" "+thirdF+" "+total;

        System.out.print(output);

        sc.close();

    }

}

更多技术干活,有趣文章,点这没错

猜你喜欢

转载自blog.csdn.net/qq_35499060/article/details/82055781