7-1 Maximum Subsequence Sum(25 分)

题目:https://pintia.cn/problem-sets/16/problems/663

Given a sequence of K integers { N 1 , N 2 , , N K }. A continuous subsequence is defined to be { N i , N i + 1 , , N j } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

 10
 -10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

代码:在线处理 T ( n ) = O ( n )

#include <stdio.h>
//#include <time.h>
#define MAX 100000
//clock_t start, stop;
//double duration;
int main(void)
{
    //start = clock();
    //stop = clock();
    int K, i, arr[MAX];
    int maxSum, tempSum, maxL, maxR, tempL, tempR;
    scanf("%d", &K);
    for(i=0; i<K; i++){
        scanf("%d", &arr[i]);
    }
    maxSum = -1; /* 子列和非负即可更新子列和的最大值及最大和子列的左右边界 */
    tempSum = 0;
    tempL = 0; /* 序列长度至少为1,初始段至少含arr[0] */
    tempR = 0;
    maxL = -1;
    maxR = -1;
    for(i=0; i<K; i++){
        tempSum += arr[i];
        tempR = i; /* 固定当前左边界,当前右边界随i增加 */
        if(tempSum>maxSum){ /* 小于或等于则不更新,以得最小的边界*/
            maxSum = tempSum;
            maxL = tempL;
            maxR = tempR;
        }
        if(tempSum<0){ /* 开始下一段固定左边界的检测 */
            tempSum = 0;
            tempL = i+1; /* 丢弃和为负的此段 */
            tempR = i+1;
        }
    }
    if(maxSum<0){
        printf("0 %d %d", arr[0], arr[K-1]);
    }
    else{
        printf("%d %d %d", maxSum, arr[maxL], arr[maxR]);
    }

    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_36913610/article/details/81274986