I - x的取余 51Nod - 1014

X*X mod P = A,其中P为质数。给出P和A,求<=P的所有X。

Input

两个数P A,中间用空格隔开。(1 <= A < P <= 1000000, P为质数)

Output

输出符合条件的X,且0 <= X <= P,如果有多个,按照升序排列,中间用空格隔开。 
如果没有符合条件的X,输出:No Solution

Sample Input

13 3

Sample Output

4 9
#include<iostream>
using namespace std;
int main()
{
	long long p,a;
	cin>>p>>a;
	int flag=0,j=0;
	long long i;
	for(i=1;i<=p;i++)
	{
		if(i*i%p==a)
		{
			if(j!=0) cout<<" ";
			j++;
			flag=1;
			cout<<i;
		}
	}
	if(flag==0) cout<<"No Solution"<<endl;
	else cout<<endl;
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41555192/article/details/81428061