hdu1130

How Many Trees?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4343    Accepted Submission(s): 2412


 

Problem Description

A binary search tree is a binary tree with root k such that any node v reachable from its left has label (v) <label (k) and any node w reachable from its right has label (w) > label (k). It is a search structure which can find a node with label x in O(n log n) average time, where n is the size of the tree (number of vertices). 

Given a number n, can you tell how many different binary search trees may be constructed with a set of numbers of size n such that each element of the set will be associated to the label of exactly one node in a binary search tree? 

 

Input

The input will contain a number 1 <= i <= 100 per line representing the number of elements of the set.

 

Output

You have to print a line in the output for each entry with the answer to the previous question.

 

Sample Input

 

1 2 3

 

Sample Output

 

1 2 5

 

Source

UVA

 

依然是卡特兰数  直接java大整数了


import java.io.*;
import java.math.*;
import java.util.*;

public class Main {
	
	public static void main(String[] args){
		
		Scanner sc = new Scanner(System.in);
		
		BigInteger s[] = new BigInteger[105];
		
		s[1] = BigInteger.ONE;
		
		for(int i = 2;i < 105;i ++){
			
			s[i] = s[i-1].multiply(BigInteger.valueOf(4 * i - 2)).divide(BigInteger.valueOf(i + 1));
				
		}
		while(sc.hasNext()){
			
			int n =  sc.nextInt();
			System.out.println(s[n]);
		}
	}
}

猜你喜欢

转载自blog.csdn.net/Soul_97/article/details/81387768