Hdu1003

Max Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 290485    Accepted Submission(s): 68875


 

Problem Description

Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

 

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

 

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

 

Sample Input

 

2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5

 

Sample Output

 

Case 1: 14 1 4 Case 2: 7 1 6

 

Author

Ignatius.L

 

Recommend

We have carefully selected several similar problems for you:  1176 1087 1069 2084 1058 

 

Statistic | Submit | Discuss | Note

总结:考察dp,最大子列和,如果当前状态大于上一个状态,子列+a[i],否则,从当前节点作为起始节点再次查找最大子列和。状态转移方程:dp[i]=max{dp[i-1],dp[i-1]+a[i]},注意结尾换行。

#include<bits/stdc++.h>
using namespace std;
int a[100100];
int main(void)
{
	int t,i,n,ok=1;
	scanf("%d",&t);
	while(t--)
	{
		memset(a,0,sizeof(a));
		scanf("%d",&n);
		for(i=1;i<=n;i++) scanf("%d",&a[i]);
		int p=1,f=1,e=1;
		int thissum=a[1],maxsum=a[1];
		for(i=2;i<=n;i++)
		{
			if(thissum+a[i]>=a[i])
			{
				thissum+=a[i];
			}
			else thissum=a[i],p=i;
			if(thissum>maxsum)
			{
				maxsum=thissum;
				f=p;
				e=i;
			}
		}
		printf("Case %d:\n%d %d %d\n",ok++,maxsum,f,e);
		if(t) printf("\n");
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41829060/article/details/81153891
今日推荐