hdu1102

Constructing Roads

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 26439    Accepted Submission(s): 10121


Problem Description
There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected. 

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.
 

Input
The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.
 

Output
You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum. 
 

Sample Input
 
  
3 0 990 692 990 0 179 692 179 0 1 1 2
 

Sample Output
 
  
179
 

Source

kicc

#include<bits/stdc++.h>
using namespace std;
const int maxn = 105;
const int inf = 0x3f3f3f3f;
int mp[maxn][maxn];
int dis[maxn],visit[maxn];
int n, m;
int prime()
{
	for(int i=1;i<=n;i++)  //先把每个点到已经建好的图中的路径置为无穷大 
		dis[i]=inf;
	dis[1]=0;              //起点为顶点1 
	for(int j=1;j<=n;j++)
	{
		int t=inf,pos;  //临时变量:最短路径距离t,和该顶点pos 
		for(int i=1;i<=n;i++)     //查找最短路径'点' 
		{
			if(!visit[i]&&t>dis[i])
			{
				t=dis[i];
				pos=i;
			}
		}
		visit[pos]=1;         //最短路径点标记为已经访问 
		for(int i=1;i<=n;i++)  //更新最短路径点 
		{
			if(!visit[i]&&dis[i]>mp[pos][i])
			{
				dis[i]=mp[pos][i];
			}
		}
	}	
	int temp=0;
	for(int k=1;k<=n;k++)
	{
		temp+=dis[k];
	}
	return temp;
}

int main()
{
	int a, b;
	while(scanf("%d",&n)!=EOF)  
    {   
        memset(visit,0,sizeof(visit));  
        for(int i=1;i<=n;i++)        //构建图的矩阵   
        {  
            for(int j=1;j<=n;j++)  
            {  
                scanf("%d",&mp[i][j]);  
            }  
        }  
        scanf("%d",&m);  
        for(int i=1;i<=m;i++)       //输入已经修建好的路   
        {  
            scanf("%d%d",&a,&b);  
            mp[a][b]=0;  
            mp[b][a]=0;  
        }  
        int ans=prime();  
        printf("%d\n",ans);  
    }  
	return 0;
}


猜你喜欢

转载自blog.csdn.net/soul_97/article/details/80216743