中石油2018年第三阶段个人训练赛第六场 I: Sandglass

题目描述

We have a sandglass consisting of two bulbs, bulb A and bulb B. These bulbs contain some amount of sand. When we put the sandglass, either bulb A or B lies on top of the other and becomes the upper bulb. The other bulb becomes the lower bulb.
The sand drops from the upper bulb to the lower bulb at a rate of 1 gram per second. When the upper bulb no longer contains any sand, nothing happens.
Initially at time 0, bulb A is the upper bulb and contains a grams of sand; bulb B contains X−a grams of sand (for a total of X grams).
We will turn over the sandglass at time r1,r2,..,rK. Assume that this is an instantaneous action and takes no time. Here, time t refer to the time t seconds after time 0.
You are given Q queries. Each query is in the form of (ti,ai). For each query, assume that a=ai and find the amount of sand that would be contained in bulb A at time ti.

Constraints
1≤X≤109
1≤K≤105
1≤r1<r2<..<rK≤109
1≤Q≤105
0≤t1<t2<..<tQ≤109
0≤ai≤X(1≤i≤Q)
All input values are integers.

样例输入

180
3
60 120 180
3
30 90
61 1
180 180

样例输出

60
1
120

题目分析:

按照顺序对翻转进行模拟,最后求出a中的沙子质量,注意使用scanf输入,不然会超时。

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
using namespace std;
int ans,x,k,q,kk[100000+5],low,up,add,now,flag;
int ca(int r,int lower=0,int upp=x)
{
    if(r<lower)
        return lower;
    if(r>upp)
        return upp;
    return r;
}
int main()
{
scanf("%d%d",&x,&k);
for(int i=1;i<=k;i++)
    scanf("%d",&kk[i]);
    now=1,flag=0,low=x;
    scanf("%d",&q);
    while(q--)
    {
        int t,a;
        scanf("%d%d",&t,&a);
    while(kk[now]<=t&&now<=k)
    {
        int dx;
        dx=(flag?1:-1)*(kk[now]-kk[now-1]);
        add+=dx;
        low=ca(dx+low);
        up=ca(dx+up);
        now++;
        flag=!flag;
    }
    ans =ca((flag ? 1 : -1) * (t - kk[now - 1]) + ca(a + add, up, low));
        cout << ans << '\n';
 
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41629316/article/details/81281322