Contest1390 - 2018年第三阶段个人训练赛第五场. Coloring Dominoes(签到题)

问题 E: Coloring Dominoes

时间限制: 1 Sec  内存限制: 128 MB
提交: 484  解决: 150
[提交] [状态] [讨论版] [命题人:admin]

题目描述

We have a board with a 2×N grid. Snuke covered the board with N dominoes without overlaps. Here, a domino can cover a 1×2 or 2×1 square.
Then, Snuke decided to paint these dominoes using three colors: red, cyan and green. Two dominoes that are adjacent by side should be painted by different colors. Here, it is not always necessary to use all three colors.
Find the number of such ways to paint the dominoes, modulo 1000000007.
The arrangement of the dominoes is given to you as two strings S1 and S2 in the following manner:
Each domino is represented by a different English letter (lowercase or uppercase).
The j-th character in Si represents the domino that occupies the square at the i-th row from the top and j-th column from the left.

Constraints
1≤N≤52
|S1|=|S2|=N
S1 and S2 consist of lowercase and uppercase English letters.
S1 and S2 represent a valid arrangement of dominoes.

输入

Input is given from Standard Input in the following format:
N
S1
S2

输出

Print the number of such ways to paint the dominoes, modulo 1000000007.

样例输入

3
aab
ccb

样例输出

6

提示

There are six ways as shown below:

参考代码:

方法一:


#include<iostream>
#include<cstring>
using namespace std;
int main()
{
    int n;
    while(cin>>n)
    {
        string a[2];
        cin>>a[0];
        cin>>a[1];
        long long ans=1;
        int flag=2;
        for(int i=0; i<n; i++)
        {
            if(flag==2)
            {
                if(a[0][i]==a[1][i])
                {
                    flag=1;
                    ans*=3;
                }
                else
                {
                    ans*=6;
                    flag=0;
                    i++;
                }
                continue;
            }
            if(a[0][i]==a[1][i])
            {
                if(flag==1)
                {
                    ans*=2;
                    ans%=1000000007;
                    flag=1;
                }
                else flag=1;
            }
            else if(a[0][i]==a[0][i+1])
            {
                if(flag==0)
                {
                    i++;
                    ans*=3;
                    ans%=1000000007;
                    flag=0;
                }
                else
                {
                    i++;
                    ans*=2;
                    ans%=1000000007;
                    flag=0;
                }
            }
        }
        ans%=1000000007;
        cout<<ans<<endl;
    }
    return 0;
}

方法二:

#include <iostream>
#include <queue>
using namespace std;
int n;
queue<int>node;
int main()
{
    string s[2];
    while(cin>>n)
    {
        cin>>s[0]>>s[1];
        if(n<=2)
        {
            cout<<n*3<<endl;
            continue;
        }

        for(int i=0; i<n; i++)
        {
            if(s[0][i] == s[1][i]) node.push(1);
            else
            {
                i++;
                node.push(0);
            }
        }
        long long ans,tt = node.front();
        node.pop();
        if(tt==0) ans=6;
        else ans=3;
        while(!node.empty())
        {
            int f = node.front();
            if(tt == 0 && f == 0)
            {
                ans*=3;
                ans%=1000000007;
            }
            else if(tt == 0 && f == 1)
                ans%=1000000007;
            else if(tt == 1)
                ans*=2;
            ans%=1000000007;
            tt = f;
            node.pop();
        }
        cout<<ans<< endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/xxxxxm1/article/details/81252847