Contest1391 - 2018年第三阶段个人训练赛第六场. Sandglass2(水题)

问题 F: Sandglass2

时间限制: 1 Sec  内存限制: 128 MB
提交: 341  解决: 210
[提交] [状态] [讨论版] [命题人:admin]

题目描述

We have a sandglass that runs for X seconds. The sand drops from the upper bulb at a rate of 1 gram per second. That is, the upper bulb initially contains X grams of sand.
How many grams of sand will the upper bulb contains after t seconds?

Constraints
1≤X≤109
1≤t≤109
X and t are integers.

输入

The input is given from Standard Input in the following format:
X t

输出

Print the number of sand in the upper bulb after t second.

样例输入

100 17

样例输出

83

提示

17 out of the initial 100 grams of sand will be consumed, resulting in 83 grams.

 注意:t>=X 时答案为 0。

#include<iostream>
using namespace std;
int main()
{
    long long n,m;
    while(cin>>n>>m)
    {
        if(m>=n)
            cout<<0<<endl;
        else
        cout<<n-m<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/xxxxxm1/article/details/81271999