upc2018年第三阶段个人训练赛第七场C题

问题 C: Restoring Road Network

http://exam.upc.edu.cn/problem.php?cid=1392&pid=2

时间限制: 1 Sec  内存限制: 128 MB
提交: 896  解决: 184
[提交] [状态] [讨论版] [命题人:admin]

题目描述

In Takahashi Kingdom, which once existed, there are N cities, and some pairs of cities are connected bidirectionally by roads. The following are known about the road network:
People traveled between cities only through roads. It was possible to reach any city from any other city, via intermediate cities if necessary.
Different roads may have had different lengths, but all the lengths were positive integers.
Snuke the archeologist found a table with N rows and N columns, A, in the ruin of Takahashi Kingdom. He thought that it represented the shortest distances between the cities along the roads in the kingdom.
Determine whether there exists a road network such that for each u and v, the integer Au,v at the u-th row and v-th column of A is equal to the length of the shortest path from City u to City v. If such a network exist, find the shortest possible total length of the roads.

Constraints
1≤N≤300
If i≠j, 1≤Ai,j=Aj,i≤109.
Ai,i=0

输入

Input is given from Standard Input in the following format:
N
A1,1 A1,2 … A1,N
A2,1 A2,2 … A2,N

AN,1 AN,2 … AN,N
 

输出

If there exists no network that satisfies the condition, print -1. If it exists, print the shortest possible total length of the roads.

样例输入

3
0 1 3
1 0 2
3 2 0

样例输出

3

提示

The network below satisfies the condition:
City 1 and City 2 is connected by a road of length 1.
City 2 and City 3 is connected by a road of length 2.
City 3 and City 1 is not connected by a road.

题意:N个城市,有些城市通过道路双向连接。如有必要,可以通过中间城市从任何其他城市到达任何城市。

A(u,v)指u到v的最短路径。给出网络A的值,问是否存在这样的网络,找到最短的道路总长度。A不成立则输出-1

思路:floyed求最短路径。若A(u,v)>u通过别的城市到达v,则A不成立,输出-1

           若A(u,v)<u通过别的城市到达v,sum+=A(u,v).

代码:

#include<iostream>
using namespace std;

int main()
{
    int n;
    cin>>n;
    long long mapp[305][305];
    for(int i=0;i<n;i++)
    {
        for(int j=0;j<n;j++)
        {
            cin>>mapp[i][j];
        }
    }
    long long sum=0;
    for(int i=0;i<n;i++)
    {
        for(int j=0;j<=i;j++)
        {
            int flag=0;
            for(int k=0;k<n;k++)
            {
                if(mapp[i][j]>mapp[i][k]+mapp[k][j])
                {
                    cout<<"-1"<<endl;
                    return 0;
                }
                else if(mapp[i][j]==mapp[i][k]+mapp[k][j]&&i!=k&&j!=k)
                {
                    flag=1;
                    break;
                    //cout<<"   "<<i<<"  "<<j<<"  "<<k<<endl;
                }
            }
            if(flag==0)
            {
                sum+=mapp[i][j];
            }
        }
    }
    cout<<sum<<endl;
    return 0;
}

猜你喜欢

转载自blog.csdn.net/sunny_hun/article/details/81318469