Roads in the North

Building and maintaining roads among communities in the far North is an expensive business. With this in mind, the roads are build such that there is only one route from a village to a village that does not pass through some other village twice. 
Given is an area in the far North comprising a number of villages and roads among them such that any village can be reached by road from any other village. Your job is to find the road distance between the two most remote villages in the area. 

The area has up to 10,000 villages connected by road segments. The villages are numbered from 1. 

Input

Input to the problem is a sequence of lines, each containing three positive integers: the number of a village, the number of a different village, and the length of the road segment connecting the villages in kilometers. All road segments are two-way.

Output

You are to output a single integer: the road distance between the two most remote villages in the area.

Sample Input

5 1 6
1 4 5
6 3 9
2 6 8
6 1 7

Sample Output

22

树的直径的应用

#include<iostream>
#include<cstring>
#include<cstdio>
#include<queue>
#include<vector>

using namespace std;

const int maxn = 100020;
int dis[maxn], ans;
bool vis[maxn];
vector<pair<int, int> > v[maxn];

int BFS(int x){
	memset(dis, 0, sizeof(dis));
	memset(vis, 0, sizeof(vis));
	queue<int>Q;
	Q.push(x); vis[x] = 1;
	int point = 0;
	while (!Q.empty()){
		int F = Q.front();
		Q.pop();
		if (dis[F] > ans){
			ans = dis[F];
			point = F;
		}
		pair <int, int> t;
		for (int i = 0; i < v[F].size(); i++){
			t = v[F][i];
			if (vis[t.first] == 0){
				vis[t.first] = 1;
				dis[t.first] = dis[F] + t.second;
				Q.push(t.first);
			}
		}
	}
	return point;
}

int main()
{
	int x, y, z;
	while(cin >> x >> y >> z){
		v[x].push_back(make_pair(y, z));
		v[y].push_back(make_pair(x, z));
	}
	ans = 0;
	int point = BFS(1);
	ans = 0;
	BFS(point);
	cout << ans << endl;
	return 0;
}

猜你喜欢

转载自blog.csdn.net/hqzzbh/article/details/81414781