POJ - 2631 Roads in the North

Building and maintaining roads among communities in the far North is an expensive business. With this in mind, the roads are build such that there is only one route from a village to a village that does not pass through some other village twice. 
Given is an area in the far North comprising a number of villages and roads among them such that any village can be reached by road from any other village. Your job is to find the road distance between the two most remote villages in the area. 

The area has up to 10,000 villages connected by road segments. The villages are numbered from 1. 

Input

Input to the problem is a sequence of lines, each containing three positive integers: the number of a village, the number of a different village, and the length of the road segment connecting the villages in kilometers. All road segments are two-way.

Output

You are to output a single integer: the road distance between the two most remote villages in the area.

Sample Input

5 1 6
1 4 5
6 3 9
2 6 8
6 1 7

Sample Output

22

题目大意: 有很多个村庄和道路,每一行输入两个村庄和这两个村庄的距离,求所有村庄距离最远的两个村庄之间的距离

解题思路:树的直径模板提,两次dfs或者bfs

AC代码:

#include<iostream>
#include<cstring>
using namespace std;
const int maxn=1e6;
int head[maxn],cnt,point,ans;

struct edge{
	int to;
	int w;
	int next;
}e[maxn];

void init()
{
	cnt=0;
	memset(head,-1,sizeof(head));
}
void add(int u,int v,int w)
{
	e[cnt].to=v;
	e[cnt].w=w;
	e[cnt].next=head[u];
	head[u]=cnt++;
}

void dfs(int u,int w,int pre)//pre表示上一次访问的节点 
{
	if(w>ans)
	{
		ans=w;
		point =u;
	}
	for(int i=head[u];~i;i=e[i].next)
	{
		int to=e[i].to;
		if(to!=pre)
			dfs(to,w+e[i].w,u);
	}
}
int main()
{
	int u,v,w;
	init();
	while(cin>>u>>v>>w)
	{
		add(u,v,w);
		add(v,u,w);
	}
	ans=0;
	dfs(1,0,-1);
	ans=0;
	dfs(point,0,-1);
	cout<<ans<<endl;
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_40707370/article/details/86656019
今日推荐