Roads in the North (树的直径)

Building and maintaining roads among communities in the far North is an expensive business. With this in mind, the roads are build such that there is only one route from a village to a village that does not pass through some other village twice. 
Given is an area in the far North comprising a number of villages and roads among them such that any village can be reached by road from any other village. Your job is to find the road distance between the two most remote villages in the area. 

The area has up to 10,000 villages connected by road segments. The villages are numbered from 1. 

Input

Input to the problem is a sequence of lines, each containing three positive integers: the number of a village, the number of a different village, and the length of the road segment connecting the villages in kilometers. All road segments are two-way.

Output

You are to output a single integer: the road distance between the two most remote villages in the area.

Sample Input

5 1 6
1 4 5
6 3 9
2 6 8
6 1 7

Sample Output

22

题目大意:给出n个村庄,要求求出两个相距最远的村庄之间的距离。

思路:两次dfs或bfs。第一次任意选一个点进行dfs(bfs)找到离它最远的点,此点就是最长路的一个端点,再以此点进行dfs(bfs),找到离它最远的点,此点就是最长路的另一个端点,于是就找到了树的直径。
 

#include<stdio.h>
#include<iostream>
#include<cstring>
#include<queue>
#include<vector>
const int maxn=100020;
using namespace std;
int dis[maxn],ans;
bool vis[maxn];
vector<pair<int,int> >  v[maxn];
int bfs(int x)
{
	memset(dis,0,sizeof(dis));
	memset(vis,0,sizeof(vis));
	queue<int>q;
	q.push(x);vis[x]=1;
	int point=0;
	while(!q.empty())
	{
		int F=q.front();
		q.pop();
		if(dis[F]>ans)
		{
			ans=dis[F];
			point=F;
		}
		pair<int ,int>t;
		for(int i=0;i<v[F].size();i++)
		{
			t=v[F][i];
			if(vis[t.first]==0)
			{
				vis[t.first]=1;
				dis[t.first]=dis[F]+t.second;
				q.push(t.first);
			}
		}
	}
	return point;
}
int main()
{
	int x,y,z;
	while(cin>>x>>y>>z)
	{
		v[x].push_back(make_pair(y,z));
		v[y].push_back(make_pair(x,z));
	}
	ans=0;
	int point =bfs(1);
	ans=0;
	bfs(point);
	cout<<ans<<endl;
	return 0;
}

猜你喜欢

转载自blog.csdn.net/aimNO_1/article/details/81413524