Jungle Roads


The Head Elder of the tropical island of Lagrishan has a problem. A burst of foreign aid money was spent on extra roads between villages some years ago. But the jungle overtakes roads relentlessly, so the large road network is too expensive to maintain. The Council of Elders must choose to stop maintaining some roads. The map above on the left shows all the roads in use now and the cost in aacms per month to maintain them. Of course there needs to be some way to get between all the villages on maintained roads, even if the route is not as short as before. The Chief Elder would like to tell the Council of Elders what would be the smallest amount they could spend in aacms per month to maintain roads that would connect all the villages. The villages are labeled A through I in the maps above. The map on the right shows the roads that could be maintained most cheaply, for 216 aacms per month. Your task is to write a program that will solve such problems.

Input
The input consists of one to 100 data sets, followed by a final line containing only 0. Each data set starts with a line containing only a number n, which is the number of villages, 1 < n < 27, and the villages are labeled with the first n letters of the alphabet, capitalized. Each data set is completed with n-1 lines that start with village labels in alphabetical order. There is no line for the last village. Each line for a village starts with the village label followed by a number, k, of roads from this village to villages with labels later in the alphabet. If k is greater than 0, the line continues with data for each of the k roads. The data for each road is the village label for the other end of the road followed by the monthly maintenance cost in aacms for the road. Maintenance costs will be positive integers less than 100. All data fields in the row are separated by single blanks. The road network will always allow travel between all the villages. The network will never have more than 75 roads. No village will have more than 15 roads going to other villages (before or after in the alphabet). In the sample input below, the first data set goes with the map above.
Output
The output is one integer per line for each data set: the minimum cost in aacms per month to maintain a road system that connect all the villages. Caution: A brute force solution that examines every possible set of roads will not finish within the one minute time limit.
Sample Input
9
A 2 B 12 I 25
B 3 C 10 H 40 I 8
C 2 D 18 G 55
D 1 E 44
E 2 F 60 G 38
F 0
G 1 H 35
H 1 I 35
3
A 2 B 10 C 40
B 1 C 20
0
Sample Output
216
30

Prim 算法:

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstdlib>
#define MAXNVEX 30
#define INFINITY 10000

using namespace std;

struct Graph
{
    int n_vex;
    int arc[27][27];
};

int Prim(Graph G)
{
    int minu,i,j,k,ans = 0;
 //   int adjvex[MAXNVEX];   //保存相关顶点的下标
    int lowcost[MAXNVEX]; //保存相关顶点权值

 //   adjvex[0] = 0;
    lowcost[0] = 0;

    //初始化操作
    for(i = 1;i < G.n_vex;i++)
    {
        lowcost[i] = G.arc[0][i];
   //     adjvex[i] = 0;
    }

    //构造最小生成树
    for(i = 1;i < G.n_vex;i++)
    {
        minu = INFINITY;
        j = 0;
        k = 0;

        //遍历全部顶点
        while(j < G.n_vex)
        {
            if(lowcost[j] != 0 && lowcost[j] < minu)
            {
                minu = lowcost[j];
                k = j;
            }
            j++;
        }
        ans += minu;
      //  printf("(%d,%d)",adjvex[k],k);
        lowcost[k] = 0;

        //链接矩阵k行遍历全部顶点
        for(j = 0;j < G.n_vex;j++)
        {
            if(lowcost[j] != 0 && lowcost[j] > G.arc[k][j])
            {
                lowcost[j] = G.arc[k][j];
               // adjvex[j] = k;
            }
        }
    }
    return ans;
}

int main()
{
    Graph G;

    while(cin>>G.n_vex && G.n_vex)
    {
        char c[5],s[5];
        int n,pn;

        for(int i = 0; i < G.n_vex;i++)
            for(int j = i;j < G.n_vex;j++)
                G.arc[i][j] = G.arc[j][i] = INFINITY;


        for(int i = 1;i < G.n_vex;i++)
        {
            scanf("%s%d",c,&n);

            while(n--)
            {
                scanf("%s%d",s,&pn);
                G.arc[c[0]- 'A'][s[0] - 'A'] = G.arc[s[0] - 'A'][c[0]- 'A'] = pn;
            }
        }

        cout<<Prim(G)<<endl;
    }
    return 0;
}

Kruskal 算法:

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#define MAXNVEX 30
#define MAXEDGE 100


using namespace std;

struct Graph
{
    int n_vex;
    int n_edges;
};
Graph G;

struct Edge
{
    int Begin;
    int End;
    int weight;
};
Edge edges[MAXEDGE];//定义边集数组

bool cmp ( Edge a ,Edge b)
{
      return a.weight < b.weight;
}
//注意

int Find(int*parent,int f)
{
    while(parent[f] > 0)
    {
        f = parent[f];
    }
    return f;
}

//kruskal 生成最小生成树
int MiniSpanTree(Graph G)
{
    int n,m,ans = 0;

    int parent[MAXNVEX]; //定义parent数组判断边与边是否形成回路

    for(int i = 0;i < G.n_vex;i++)
    {
        parent[i] = 0;
    }

    for(int i = 0;i < G.n_edges;i++)
    {
        n = Find(parent,edges[i].Begin);
        m = Find(parent,edges[i].End);

        if(n != m) //如果m==n则形成回路,不满足
        {
            parent[n] = m; //将此边的结尾顶点放入下标为起点的parent数组中,表示此顶点已在生成树中
            ans += edges[i].weight;
        }
    }
    return ans;
}

int main()
{
    while ( cin >> G.n_vex && G.n_vex )
      {
          int i,k = 0 ;
          for ( i = 0 ; i < G.n_vex - 1 ; i ++ )
          {
              //构造边的信息
              char str[3],s[3];
              int m,t;
              cin >> str >> m ;
              while(m--)
              {
                  cin >> s >> t ;
                  edges[k].Begin = (str[0]-'A');
                  edges[k].End = (s[0]-'A');
                  edges[k].weight = t;
                  k++;
              }
          }
          G.n_edges = k;
          sort ( edges , edges + k , cmp );//将边从小到大排序

          cout<<MiniSpanTree(G)<<endl;
      }

    return 0;
}

猜你喜欢

转载自blog.csdn.net/tong_zhi/article/details/79872094