A - Constructing Roads

There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected.

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

Input

The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

Output

You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.

Sample Input

3

0 990 692

990 0 179

692 179 0

1

1 2

Sample Output

179

  • 题意概括  :

N个村庄修路,现已有m个村庄之间修好了路,问要使所有村庄都连通,求需要修路的最小长度。

  • 解题思路  :

输入数据,将图存入一个数组里,然后用Kruskal算法即可。

#include<stdio.h>
#include<string.h>
#include<algorithm>

using namespace std;

int f[110];

struct node
{
	int u,v,w;
}e[10010];

int getf(int x)
{
	if(f[x] != x)
	f[x] = getf(f[x]);
	return f[x];
}
int merge(int x,int y)
{
	int t1,t2;
	t1 = getf(x);
	t2 = getf(y);
	if(t1!= t2)
	{
		f[t2] = t1;
		return 1;
	}
	return 0;
}
int cmp(node x,node y)
{
	return x.w<y.w;
}
int main()
{
	int n,i,j,k,w,m,x,y,sum;
	while(~ scanf("%d",&n))
	{
		for(i = 1;i<=n;i ++)
		{
			f[i] = i;
		}
		k = 0;
		for(i = 1;i<=n;i ++)
		{
			for(j = 1;j<=n;j ++)
			{
				scanf("%d",&w);
				if(j>i)
				{
					e[k].u = i;
					e[k].v = j;
					e[k].w = w;
					k ++;
				}
			}
		}
		sort(e,e+k,cmp);
		scanf("%d",&m);
		for(i = 0;i<m;i ++)
		{
			scanf("%d %d",&x,&y);
			merge(x,y);
		}
		sum = 0;
		for(i = 0;i<k;i ++)
		{
			if(merge(e[i].u,e[i].v))
			{
				sum += e[i].w;
			}
		}
		printf("%d\n",sum);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/y1356998843/article/details/81332912