POJ 2631Roads in the North【树的直径】【模板题】

POJ 2631:Roads in the North

 

总时间限制: 

1000ms

内存限制: 

65536kB

描述

Building and maintaining roads among communities in the far North is an expensive business. With this in mind, the roads are build such that there is only one route from a village to a village that does not pass through some other village twice. 
Given is an area in the far North comprising a number of villages and roads among them such that any village can be reached by road from any other village. Your job is to find the road distance between the two most remote villages in the area. 

The area has up to 10,000 villages connected by road segments. The villages are numbered from 1. 

输入

Input to the problem is a sequence of lines, each containing three positive integers: the number of a village, the number of a different village, and the length of the road segment connecting the villages in kilometers. All road segments are two-way.

输出

You are to output a single integer: the road distance between the two most remote villages in the area.

样例输入

5 1 6
1 4 5
6 3 9
2 6 8
6 1 7

样例输出

22

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <vector>
#include <cstring>
#include <queue>
using namespace std;
 
const int N = 50000;
struct Node
{
	int to,value;
};
vector<Node> v[N];
int vis[N],dis[N];
int ans;
 
int BFS(int x)
{
	memset(dis,0,sizeof(dis));
	memset(vis,0,sizeof(vis));
	queue<int> q;
	q.push(x);
	vis[x]=1;
	int point = 0;
	while(!q.empty())
	{
		int f=q.front();
		q.pop();
		if(dis[f]>ans)
		{
			ans = dis[f];
			point = f;
		}
		Node tmp;
		for(int i=0;i<v[f].size();i++)
		{
			tmp = v[f][i];
			if(vis[tmp.to]==0)
			{
				vis[tmp.to]=1;
				dis[tmp.to] = dis[f] + tmp.value;
				q.push(tmp.to);
			}
		}
	}
	return point;
}
int main()
{

		int x,y,z;
		char c;
		while(cin>>x>>y>>z)
		{
			v[x].push_back((Node) {y,z});
			v[y].push_back((Node) {x,z});
		}
		
		ans = 0;
		int point = BFS(1);
		ans = 0;
		BFS(point);
		
		cout<<ans<<endl;
	
	return 0;
}

在DEV运行没有结果~~,大佬告诉我要加  ctrl +Z 

//使用了pair函数的AC code
# include <iostream>
# include <cstring>
# include <queue >
# include <vector >
const int maxn =100020;
using namespace std;
int dis[ maxn ],ans;
bool vis[ maxn ];

vector <pair <int ,int > > V[maxn];//声明不定长数组vector,存边的关系 

int bfs(int x)
{
	memset (dis ,0, sizeof (dis ));
	memset (vis ,0, sizeof (vis ));
	queue <int >Q;
	Q. push (x); 
	vis[x]=1;
	int point =0;
 	while (!Q. empty ())
	{
		int F=Q. front ();//队列最底端 
		Q.pop ();
		if(dis[F]>ans)
		{
		ans =dis [F];
		point =F;
		}
		pair <int ,int >t;//v[f][i].first表示f点连出去的第i个点的编号,v[f][i].second表示f点连出去的第i条边的权值 
		for (int i=0;i<V[F]. size ();i ++)//V[F]. size ()容器大小 
		{
		 	t=V[F][i];
			if(vis [t. first ]==0)
			{
			 	vis [t. first ]=1;
			 	dis [t. first ]= dis[F]+t. second ;
				Q. push (t. first );
			}
		}
	}
 return point ;
}
int main ()
{
	int x,y,z;
	//建图,将边的关系存入v数组   
	while (cin>>x>>y>>z)
	{
		V[x]. push_back ( make_pair (y,z));//V.push_back() 数据的插入;
		V[y]. push_back ( make_pair (x,z));
	}
 	ans =0;
 	int point =bfs (1);//第一次BFS找直径的一个端点 point 
	ans =0;
	bfs( point );//第二次,对point用BFS,确定树的直径 
	cout <<ans << endl ;
	return 0;
 }

猜你喜欢

转载自blog.csdn.net/tingtingyuan/article/details/81412483
今日推荐