POJ-2318-TOYS(简单计算几何,两种做法)

TOYS

Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 19721   Accepted: 9291

Description

Calculate the number of toys that land in each bin of a partitioned toy box. 
Mom and dad have a problem - their child John never puts his toys away when he is finished playing with them. They gave John a rectangular box to put his toys in, but John is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for John to find his favorite toys. 

John's parents came up with the following idea. They put cardboard partitions into the box. Even if John keeps throwing his toys into the box, at least toys that get thrown into different bins stay separated. The following diagram shows a top view of an example toy box. 
 
For this problem, you are asked to determine how many toys fall into each partition as John throws them into the toy box.

Input

The input file contains one or more problems. The first line of a problem consists of six integers, n m x1 y1 x2 y2. The number of cardboard partitions is n (0 < n <= 5000) and the number of toys is m (0 < m <= 5000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1,y1) and (x2,y2), respectively. The following n lines contain two integers per line, Ui Li, indicating that the ends of the i-th cardboard partition is at the coordinates (Ui,y1) and (Li,y2). You may assume that the cardboard partitions do not intersect each other and that they are specified in sorted order from left to right. The next m lines contain two integers per line, Xj Yj specifying where the j-th toy has landed in the box. The order of the toy locations is random. You may assume that no toy will land exactly on a cardboard partition or outside the boundary of the box. The input is terminated by a line consisting of a single 0.

Output

The output for each problem will be one line for each separate bin in the toy box. For each bin, print its bin number, followed by a colon and one space, followed by the number of toys thrown into that bin. Bins are numbered from 0 (the leftmost bin) to n (the rightmost bin). Separate the output of different problems by a single blank line.

Sample Input

5 6 0 10 60 0
3 1
4 3
6 8
10 10
15 30
1 5
2 1
2 8
5 5
40 10
7 9
4 10 0 10 100 0
20 20
40 40
60 60
80 80
 5 10
15 10
25 10
35 10
45 10
55 10
65 10
75 10
85 10
95 10
0

Sample Output

0: 2
1: 1
2: 1
3: 1
4: 0
5: 1

0: 2
1: 2
2: 2
3: 2
4: 2

Hint

As the example illustrates, toys that fall on the boundary of the box are "in" the box.

Source

Rocky Mountain 2003

题目大意:给你一个矩形,然后再给你n条将这些矩形分为n+1个区域的线段,再给你m个点,问你这n+1个区域内的点的个数

两种做法:

第一种:暴力,直接将每个点和每条线段进行判断:只有在左边才算是落在区域内

然后要用c++交,不然会超时

代码:

/*
给出矩形四个点的坐标,和m个玩具的坐标,现在从左到右给出n条两两不想交的线段
问每个区域内有多少个玩具9点)
思路1:判断点和直线的关系
*/
#include<map>
#include<stack>
#include<queue>
#include<string>
#include<cmath>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<iostream>
#include<algorithm>
using namespace std;
#define ll long long
#define ul unsigned long long
#define bug printf("mmp\n");
#define inf 0x3f3f3f3f
#define esp 1e-6
#define mm(a,b) memset(a,b,sizeof(a))
#define T()int test,q=1,tt;scanf("%d",&test),tt=test;while(test--)
const int N=1e3+10;
const int maxn=1e6+100;
struct point
{
    double x,y;
} num[maxn];
struct line
{
    point st,ed;///线段的端点
    double k,b;///直线的斜率和截距
} l[maxn];
int number[maxn];
int main()
{
    int m,n;
    point a,b,c,d;///矩形四个点
    while(scanf("%d",&n)&&n)
    {
        memset(number,0,sizeof(number));
        cin>>m>>a.x>>a.y>>c.x>>c.y;
        b.x=c.x,b.y=a.y;
        d.x=a.x,d.y=c.y;
        for(int i=0; i<n; i++)
        {
            l[i].st.y=a.y;
            l[i].ed.y=c.y;
            cin>>l[i].st.x>>l[i].ed.x;
            if(l[i].st.x==l[i].ed.x)///与矩形垂直
            {
                l[i].k=0;
                l[i].b=0;
                continue;
            }
            else///计算直线的斜率和截距
            {
                l[i].k=(l[i].ed.y-l[i].st.y)/(l[i].ed.x-l[i].st.x);
                l[i].b=l[i].ed.y-l[i].k*l[i].ed.x;
            }
        }
        l[n].k=0,l[n].b=0;///最后一条直线
        l[n].st=b,l[n].ed=c;
        double x,y;
        ///只能判断在左边,右边不能直接判断
        for(int i=0; i<m; i++)
        {
            cin>>x>>y;
            for(int j=0; j<=n; j++) ///逐个判断
            {
                if(l[j].k==0)///当线段垂直时比较一下该点和端点的关系
                {
                    if(x<l[j].st.x)
                    {
                        number[j]++;
                        break;
                    }
                }
                else if(l[j].k>0)
                {
                    if(y>l[j].k*x+l[j].b)
                    {
                        number[j]++;
                        break;
                    }
                }
                else if(l[j].k<0)
                {
                    if(y<l[j].k*x+l[j].b)
                    {
                        number[j]++;
                        break;
                    }
                }
            }
        }
        for(int i=0; i<=n; i++)
        {
            printf("%d: %d\n",i,number[i]);
        }
        printf("\n");
    }
    return 0;
}

第二种:利用叉积判断点与直线的关系再加上二分

代码:

/*
给出矩形四个点的坐标,和m个玩具的坐标,现在从左到右给出n条两两不想交的线段
问每个区域内有多少个玩具9点)
思路2:利用向量叉积与二分
*/
#include<map>
#include<stack>
#include<queue>
#include<string>
#include<cmath>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<iostream>
#include<algorithm>
using namespace std;
#define ll long long
#define ul unsigned long long
#define bug printf("mmp\n");
#define inf 0x3f3f3f3f
#define esp 1e-6
#define mm(a,b) memset(a,b,sizeof(a))
#define T()int test,q=1,tt;scanf("%d",&test),tt=test;while(test--)
const int N=1e3+10;
const int maxn=1e6+100;
struct point
{
    double x,y;
} num[maxn];
struct line
{
    point st,ed;///线段的端点
    double k,b;///直线的斜率和截距
} l[maxn];
int number[maxn];
double mul(point a,point b,point c)
{
    return (a.x-c.x)*(b.y-c.y)-(b.x-c.x)*(a.y-c.y);
}
void b_search(point a,int n)
{
    int li=0,ri=n-1;
    int mid;
    while(li<ri)
    {
        mid=(li+ri)/2;
        if(mul(a,l[mid].st,l[mid].ed)>0)
            li=mid+1;
        else
            ri=mid;
    }
    if(mul(a,l[li].st,l[li].ed)>0)
        number[li+1]++;
    else
        number[li]++;
}
int main()
{
    int m,n;
    point a,b,c,d;///矩形四个点
    while(scanf("%d",&n)&&n)
    {
        memset(number,0,sizeof(number));
        cin>>m>>a.x>>a.y>>c.x>>c.y;
        b.x=c.x,b.y=a.y;
        d.x=a.x,d.y=c.y;
        for(int i=0; i<n; i++)
        {
            l[i].st.y=a.y;
            l[i].ed.y=c.y;
            cin>>l[i].st.x>>l[i].ed.x;
        }
        double x,y;
        ///只能判断在左边,右边不能直接判断
        for(int i=0; i<m; i++)
        {
            cin>>x>>y;
            point A;
            A.x=x,A.y=y;
            b_search(A,n);
        }
        for(int i=0; i<=n; i++)
        {
            printf("%d: %d\n",i,number[i]);
        }
        printf("\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/lee371042/article/details/86133769