HDU6312 Game 多校签到题???!

Game

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 459    Accepted Submission(s): 325

 

Problem Description

Alice and Bob are playing a game.
The game is played on a set of positive integers from 1 to n.
In one step, the player can choose a positive integer from the set, and erase all of its divisors from the set. If a divisor doesn't exist it will be ignored.
Alice and Bob choose in turn, the one who cannot choose (current set is empty) loses.
Alice goes first, she wanna know whether she can win. Please judge by outputing 'Yes' or 'No'.

Input

There might be multiple test cases, no more than 10. You need to read till the end of input.
For each test case, a line containing an integer n. (1≤n≤500)

Output

A line for each test case, 'Yes' or 'No'.

Sample Input

1

Sample Output

Yes

 

一看很懵,感觉应该有很多种情况很复杂的样子,真是给跪。大概有点儿博弈的感觉叭。

然而!然而!

然我们吧1与2~n分开来想:

先考虑2~n:

if 2~n中有一个Alice第一次选择之后必然会赢,那么选那个数字即可;

else  没有一个数字能够第一次选择之后会赢的话,那么Alice先选1即可;    //Bob必定选到Alice能赢的数字

所以,这是个必胜局!

嘤!

#include <cstdio>

int main()
{
	int n;

	while(~scanf("%d",&n)){
		printf("Yes\n");
	}

	return 0;
}

猜你喜欢

转载自blog.csdn.net/DADDY_HONG/article/details/81221443
今日推荐