Game-hdu6312

Alice and Bob are playing a game. 
The game is played on a set of positive integers from 1 to n. 
In one step, the player can choose a positive integer from the set, and erase all of its divisors from the set. If a divisor doesn't exist it will be ignored. 
Alice and Bob choose in turn, the one who cannot choose (current set is empty) loses. 
Alice goes first, she wanna know whether she can win. Please judge by outputing 'Yes' or 'No'.

Input

There might be multiple test cases, no more than 10. You need to read till the end of input. 
For each test case, a line containing an integer n. (1≤n≤5001≤n≤500) 

Output

A line for each test case, 'Yes' or 'No'. 

Sample Input

1

Sample Output

Yes

直接取1把所有项消掉

#include<iostream>
#include<cstring>
#include<cstdio> 
using namespace std;
int main()
{
	int n;
	while(~scanf("%d",&n))
	{
		printf("Yes\n");
	}
	
	return 0;
} 	

猜你喜欢

转载自blog.csdn.net/qq_43568078/article/details/88968932