Advanced Fruits(最长公共子序列)

The company "21st Century Fruits" has specialized in creating new sorts of fruits by transferring genes from one fruit into the genome of another one. Most times this method doesn't work, but sometimes, in very rare cases, a new fruit emerges that tastes like a mixture between both of them. 
A big topic of discussion inside the company is "How should the new creations be called?" A mixture between an apple and a pear could be called an apple-pear, of course, but this doesn't sound very interesting. The boss finally decides to use the shortest string that contains both names of the original fruits as sub-strings as the new name. For instance, "applear" contains "apple" and "pear" (APPLEar and apPlEAR), and there is no shorter string that has the same property.
A combination of a cranberry and a boysenberry would therefore be called a "boysecranberry" or a "craboysenberry", for example.
Your job is to write a program that computes such a shortest name for a combination of two given fruits. Your algorithm should be efficient, otherwise it is unlikely that it will execute in the alloted time for long fruit names. 

Input

Each line of the input contains two strings that represent the names of the fruits that should be combined. All names have a maximum length of 100 and only consist of alphabetic characters. 

Input is terminated by end of file. 

Output

For each test case, output the shortest name of the resulting fruit on one line. If more than one shortest name is possible, any one is acceptable. 

Sample Input

apple peach

ananas banana

pear peach

Sample Output

appleach

bananas

pearch

之前我做过一个类似的求最长公共子序列的模板题,和网上大多数题解模板不一样,但是也能很好的理解并打印公共子序列。

见这里:https://blog.csdn.net/shezjoe/article/details/81185794

这道题要求打印两个字符串连在一起并且公共子序列只打印一次,我在之前的模板里修改了很久还是无法实现,可能是方法不对,太菜了。。。以后想出来了再更新。
这里贴出网上的一种使用较多的模板,稍作改动可以a这道题方法很巧妙。

#include<map>
#include<cmath>
#include<queue>
#include<stack>
#include<string>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#define inf 0x3f3f3f3f
using namespace std;
typedef long long LL;
int k1,k2;
int dp[1100][1100];
int mark[1100][1100];
char s1[1100],s2[1100];
int lsc()
{
    memset(dp,0,sizeof(dp));
    for(int i=0; i<=k1; i++)
        mark[i][0]=1;
    for(int i=0; i<=k2; i++)
        mark[0][i]=-1;
    for(int i=1; i<=k1; i++)
    {
        for(int j=1; j<=k2; j++)
        {
            if(s2[j]==s1[i])
            {
                dp[i][j]=dp[i-1][j-1]+1;
                mark[i][j]=0;
            }
            else if(dp[i-1][j]>=dp[i][j-1])
            {
                dp[i][j]=dp[i-1][j];
                mark[i][j]=1;
            }
            else
            {
                dp[i][j]=dp[i][j-1];
                mark[i][j]=-1;
            }
        }
    }
}
void p_lsc(int i,int j)
{
    if(!i&&!j)
        return;
    if(mark[i][j]==0)
    {
        p_lsc(i-1,j-1);
        printf("%c",s1[i]);
    }
    else if(mark[i][j]==1)
    {
        p_lsc(i-1,j);
        printf("%c",s1[i]);//输出s1里边除了公共子序列之外的
    }
    else if(mark[i][j]==-1)
    {
        p_lsc(i,j-1);
        printf("%c",s2[j]); //输出s2里边除了公共子序列之外的
    }
}
int main()
{
    while(~scanf("%s%s",s1+1,s2+1))
    {
        k1=strlen(s1+1);
        k2=strlen(s2+1);
        lsc();
        p_lsc(k1,k2);
        printf("\n");
    }
}

猜你喜欢

转载自blog.csdn.net/shezjoe/article/details/81198921
今日推荐