hdu 1503 Advanced Fruits

Advanced Fruits

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4410    Accepted Submission(s): 2306
Special Judge


Problem Description
The company "21st Century Fruits" has specialized in creating new sorts of fruits by transferring genes from one fruit into the genome of another one. Most times this method doesn't work, but sometimes, in very rare cases, a new fruit emerges that tastes like a mixture between both of them. 
A big topic of discussion inside the company is "How should the new creations be called?" A mixture between an apple and a pear could be called an apple-pear, of course, but this doesn't sound very interesting. The boss finally decides to use the shortest string that contains both names of the original fruits as sub-strings as the new name. For instance, "applear" contains "apple" and "pear" (APPLEar and apPlEAR), and there is no shorter string that has the same property. 

A combination of a cranberry and a boysenberry would therefore be called a "boysecranberry" or a "craboysenberry", for example. 

Your job is to write a program that computes such a shortest name for a combination of two given fruits. Your algorithm should be efficient, otherwise it is unlikely that it will execute in the alloted time for long fruit names. 
 

Input
Each line of the input contains two strings that represent the names of the fruits that should be combined. All names have a maximum length of 100 and only consist of alphabetic characters.

Input is terminated by end of file. 
 

Output
For each test case, output the shortest name of the resulting fruit on one line. If more than one shortest name is possible, any one is acceptable.
 

Sample Input
 
  
apple peach ananas banana pear peach
 

Sample Output
 
  
appleach bananas pearch
 

Source
 

Recommend
linle   |   We have carefully selected several similar problems for you:   1502  1501  1227  1080  1158 
LCS 模板题,加上标记数组,递归输出
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define N 105
char s1[N],s2[N];
int f[N][N];//记录当前字母前面的最长公共子序列的长度 
int mark[N][N];//保存状态 s1与s2对应字符的匹配状态 
int l1,l2;
void LCS()
{
	for(int i=0;i<=l1;i++)
	{
	  f[i][0]=0;
	   mark[i][0]=1;
    }
	for(int i=0;i<=l2;i++)
	{
	  f[0][i]=0;
	  mark[0][i]=-1;
	}
	for(int i=1;i<=l1;i++)
	{
		for(int j=1;j<=l2;j++)
		{
			if(s1[i-1]==s2[j-1])
			{
				mark[i][j]=0;
				f[i][j]=f[i-1][j-1]+1;
			}
			else if(f[i-1][j]>f[i][j-1])
			{
				mark[i][j]=1;
				f[i][j]=f[i-1][j];
			}
			else{
				mark[i][j]=-1;
				f[i][j]=f[i][j-1];
			}
		}
	}
}
void print(int i,int j)
{
	if(!i&&!j)
	return ;
	if(mark[i][j]==0)
	{
		print(i-1,j-1);
		printf("%c",s1[i-1]);
	}
	else if(mark[i][j]==1)
	{
		print(i-1,j);
		printf("%c",s1[i-1]);
	}
	else {
		print(i,j-1);
		printf("%c",s2[j-1]);
	}
}
int main()
{
	while(~scanf("%s%s",s1,s2))
	{
		l1=strlen(s1);
		l2=strlen(s2);
		LCS();
		print(l1,l2);
		printf("\n");
	}
}

猜你喜欢

转载自blog.csdn.net/qq_36914923/article/details/80085227