Wormholes

题目:

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input
Line 1: A single integer,  FF farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively:  NM, and  W 
Lines 2..  M+1 of each farm: Three space-separated numbers (  SET) that describe, respectively: a bidirectional path between  S and  E that requires  T seconds to traverse. Two fields might be connected by more than one path. 
Lines  M+2..  MW+1 of each farm: Three space-separated numbers (  SET) that describe, respectively: A one way path from  S to  E that also moves the traveler back T seconds.
Output
Lines 1..  F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).
Sample Input
2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8
Sample Output
NO
YES


题意:

大意,给出几个点,其中距离为正为负的已经分别给出,让我们判断是否有负环存在

代码:

#include <cstdio>
#include <iostream>
#include <cstring>
using namespace std;
const int inf=(1<<30);
int f,n,m,w,total;
int s[5500],e[5500],t[5500];
void read()
{
    int i;
    total=1;
    int a,b,c;
    scanf("%d %d %d",&n,&m,&w);
    while(m--)
    {
        scanf("%d %d %d",&a,&b,&c);
        s[total]=a;
        e[total]=b;
        t[total++]=c;
        s[total]=b;
        e[total]=a;
        t[total++]=c;
    }
    while(w--)
    {
        scanf("%d %d %d",&a,&b,&c);
        s[total]=a;
        e[total]=b;
        t[total++]=-c;
    }
}
bool bellman_ford()
{
    int i,j;
    int dis[5500];
    for(i=1;i<=n;i++)
        dis[i]=inf;
    dis[1]=0;
    for(i=1;i<n;i++)
    {
        for(j=1;j<=total;j++)
        {
            int x=s[j];
            int y=e[j];
            if(dis[x]<inf&&dis[y]>dis[x]+t[j])
                dis[y]=dis[x]+t[j];
        }
    }
    for(i=1;i<=total;i++)
        if(dis[e[i]]>dis[s[i]]+t[i])
        return true;
    return false;
}
int main()
{
    scanf("%d",&f);
    while(f--)
    {
        read();
        if(bellman_ford())
            printf("YES\n");
        else
            printf("NO\n");


    }
}

猜你喜欢

转载自blog.csdn.net/stdio_xuege/article/details/81066030