F - Wormholes POJ - 3259

F - Wormholes

POJ - 3259

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2.. M+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2.. M+ W+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output

Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

//#include<bits/stdc++.h>
#define _CRT_SBCURE_NO_DEPRECATE
#include <set>
#include <cmath>
#include <queue>
#include <stack>
#include <vector>
#include <string>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <functional>
//#define UP(i,x,y) for(int i=x;i<=y;i++)
//#define DOWN(i,x,y) for(int i=x;i>=y;i--)
#define sd(x,y,z) scanf("%d%d%d", &x, &y, &z)
//#define sd(x,y) scanf("%d%d%d", &x, &y)
#define pb push_back
#define long long ll
using namespace std;
const int maxn = 1010;
const int INF = 0x3f3f3f3f;

int n, m, w, t;
struct wh
{
    int from;
    int to;
    int cost;
    wh(int f,int t,int c):from(f),to(t),cost(c){}
    wh(){}
    //edge(int t, double c):to(t),cost(c){}
};
wh G[maxn*maxn*2];
int d[maxn];
int cnt = 0;
void init()
{
    d[1] = 0;
    for(int j = 0; j < maxn*maxn*2; ++j)
    {
        G[j].from = 0;
        G[j].to = 0;
        G[j].cost = INF;
    }
}
bool ford()
{
    d[1] = 0;
    for(int i = 1; i <= n; ++i)
    {
        for(int j = 0; j < cnt; ++j)
        {
            if(d[G[j].to] > d[G[j].from]+G[j].cost)
            {
                d[G[j].to] = d[G[j].from]+G[j].cost;
                if(i == n)
                    return true;
            }
        }
    }
    return false;
}
int main()
{
    //freopen("in.txt", "r", stdin);
    scanf("%d", &t);
	while(t--)
    {
        scanf("%d%d%d", &n, &m, &w);
        cnt = 0;
        init();
        int ta, tb, tc;
        for(int i = 0; i < m; ++i)
        {
            scanf("%d%d%d", &ta, &tb, &tc);
            G[cnt].from = ta;
            G[cnt].to = tb;
            G[cnt++].cost = tc;
            G[cnt].from = tb;
            G[cnt].to = ta;
            G[cnt++].cost = tc;
        }
        for(int i = 0; i < w; ++i)
        {
            scanf("%d%d%d", &ta, &tb, &tc);
            G[cnt].from = tb;
            G[cnt].to = ta;
            G[cnt++].cost = -tc;
        }
        bool flag = ford();
        if(flag)
            printf("YES\n");
        else
            printf("NO\n");
    }
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_40758751/article/details/81431153