Wormholes(POJ 3259)

Time Limit : 4000/2000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)

Total Submission(s) : 7   Accepted Submission(s) : 2

Problem Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, F. F farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively: N, M, and W 
Lines 2.. M+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path. 
Lines M+2.. M+ W+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output

Lines 1..F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2

3 3 1

1 2 2

1 3 4

2 3 1

3 1 3

3 2 1

1 2 3

2 3 4

3 1 8

Sample Output

NO

YES

Source

PKU

题目大意:虫洞问题,现在有n个点,m条边,代表现在可以走的通路,比如从a到b和从b到a需要花费c时间,现在在地上出现了w个虫洞,虫洞的意义就是你从a到b花费的时间是-c(时间倒流,并且虫洞是单向的),现在问你从某个点开始走,能回到从前?

解题思路:其实给出了坐标,这个时候就可以构成一张图,然后将“回到从前”理解为“是否会出现负权环”,只要判断是否有负权环就行了。

#include<bits/stdc++.h>
using namespace std;
const int inf=1<<30;
int dist[10000],N,M,W;
struct edge
{
    int s,e,w;
    edge(int ss,int ee,int ww)
    {
        s=ss,e=ee,w=ww;
    }
};
vector<edge>edges;
bool Bellman_ford(int v)
{
    for(int i=1;i<=N;i++) dist[i]=inf;
    dist[v]=0;
    for(int k=1;k<N;k++) //N-1轮松弛
    {
        bool flag=false;
        for(int i=0;i<edges.size();i++) //扫描所有边
        {
            int s=edges[i].s;
            int e=edges[i].e;
            if(dist[s]+edges[i].w<dist[e]) //松弛
                flag=true,dist[e]=dist[s]+edges[i].w;
        }
        if(!flag) break;
    }
    for(int i=0;i<edges.size();i++) //再进行一次松弛,检查有没有负权回路,如果出现更短路,则有负权边
    {
        int s=edges[i].s;
        int e=edges[i].e;
        if(dist[s]+edges[i].w<dist[e])
            return true;
    }
    return false;
}
int main()
{
    int F;
    scanf("%d",&F);
    while(F--)
    {
        edges.clear();
        scanf("%d%d%d",&N,&M,&W);
        for(int i=0;i<M;i++)
        {
            int s,e,t;
            scanf("%d%d%d",&s,&e,&t);
            edges.push_back(edge(s,e,t));
            edges.push_back(edge(e,s,t));
        }
        for(int i=0;i<W;i++)
        {
            int s,e,t;
            scanf("%d%d%d",&s,&e,&t);
            edges.push_back(edge(s,e,-t));
        }
        if(Bellman_ford(1)) printf("YES\n");//从1可达所有点
        else printf("NO\n");

    }
}

猜你喜欢

转载自blog.csdn.net/qq_41061455/article/details/81368178
今日推荐