poj3259 Wormholes

Wormholes
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 50389   Accepted: 18606

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer,  FF farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively:  NM, and  W 
Lines 2.. M+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: a bidirectional path between  S and  E that requires  T seconds to traverse. Two fields might be connected by more than one path. 
Lines  M+2.. M+ W+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: A one way path from  S to  E that also moves the traveler back  T seconds.

Output

Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

扫描二维码关注公众号,回复: 1548945 查看本文章
For farm 1, FJ cannot travel back in time. 
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

本质就是求是否存在负圈

//
// Created by Admin on 2017/5/2.
//

#include <cstdio>
#include <cstring>

struct edge{
    int from,to,cost;
}ed[6000];
int n,m,w,d[510];

int shortpath(int s){
    memset(d,0, sizeof(d));
    for (int i = 0; i < n; ++i) {
        for (int j = 0; j < s; ++j) {
            edge e=ed[j];
            if(d[e.to]>d[e.from]+e.cost){
                d[e.to]=d[e.from]+e.cost;

                //如果第n次任然更新了,则存在负圈
                if(i==n-1)return 1;
            }
        }
    }
    return 0;
}

int main(){
    int f;
    scanf("%d",&f);
    while (f--){
        scanf("%d%d%d",&n,&m,&w);
        int cnt=0,a,b,c;;
        for (int i = 0; i < m; ++i) { //双向边
            scanf("%d%d%d",&a,&b,&c);
            ed[cnt].from=a;
            ed[cnt].to=b;
            ed[cnt++].cost=c;
            ed[cnt].from=b;
            ed[cnt].to=a;
            ed[cnt++].cost=c;
        }
        for (int j = 0; j < w; ++j) {  //单向负边
            scanf("%d%d%d",&a,&b,&c);
            ed[cnt].from=a;
            ed[cnt].to=b;
            ed[cnt++].cost=-c;
        }
        if(shortpath(cnt))printf("YES\n");
        else printf("NO\n");
    }
    return 0;
}


猜你喜欢

转载自blog.csdn.net/qq_32767041/article/details/71104989