POJ 3259—Wormholes

版权声明:请联系[email protected] https://blog.csdn.net/wanglin007/article/details/84431096

题下:POJ 3259—Wormholes

Time Limit: 2000MS		Memory Limit: 65536K
Total Submissions: 66356		Accepted: 24748
Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, F. F farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively: N, M, and W 
Lines 2..M+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path. 
Lines M+2..M+W+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.
Output

Lines 1..F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).
Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8
Sample Output

NO
YES
Hint

For farm 1, FJ cannot travel back in time. 
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.
Source

USACO 2006 December Gold

解题报告(注释题解):

#include<iostream>
using namespace std;
const int inf=10010;
struct node{
	int f,t,c;
};
int S,E,T,N,M,W,NUM;
node n[5200];
int bellman_ford()
{
	int dis[505];
	dis[0]=0; 
	for(int i=1;i<N;i++)dis[i]=inf;//开始时设每一个点到别的点的距离无限大。就是每个点的权值 
	for(int i=1;i<N;i++)//以这个图的点得个数为外层循环,,由于是从任一点开始,所以这层循环求的是任一点的最短距离。 
	{
		int flag=0;
		for(int j=1;j<=NUM;j++)//以有向边的个数为内层循环,对每一个边进行松弛。 
		{
			if(dis[n[j].t]>dis[n[j].f]+n[j].c)
			{
				dis[n[j].t]=dis[n[j].f]+n[j].c;
				flag=1;//当循环进不来时说明不能松弛了。 
			}
		}
		if(!flag)break;//不能松弛就跳出循环。 
	}
	for(int i=1;i<=NUM;i++)
	{
		if(dis[n[i].t]>dis[n[i].f]+n[i].c)
		return true;
	}
	return false;
}
int main()
{
	int nn;
	cin>>nn;
	while(nn--)
	{
		NUM=1;
		cin>>N>>M>>W;
		while(M--)
		{
			cin>>S>>E>>T;
			n[NUM].f=S;
			n[NUM].t=E;
			n[NUM++].c=T;//无向边,故需要将两个方向都记下。 
			n[NUM].f=E;
			n[NUM].t=S;
			n[NUM++].c=T;
		}
		while(W--)
		{
			cin>>S>>E>>T;
			n[NUM].f=S;
			n[NUM].t=E;
			n[NUM++].c=(0-T);
		}
		if(bellman_ford())
		cout<<"YES"<<endl;
		else
		cout<<"NO"<<endl;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/wanglin007/article/details/84431096