AtCoder Beginner Contest 071 D - Coloring Dominoes

D - Coloring Dominoes


Time limit : 2sec / Memory limit : 256MB

Score : 400 points

Problem Statement

We have a board with a 2×N grid. Snuke covered the board with N dominoes without overlaps. Here, a domino can cover a 1×2 or 2×1 square.

Then, Snuke decided to paint these dominoes using three colors: red, cyan and green. Two dominoes that are adjacent by side should be painted by different colors. Here, it is not always necessary to use all three colors.

Find the number of such ways to paint the dominoes, modulo 1000000007.

The arrangement of the dominoes is given to you as two strings S1 and S2 in the following manner:

  • Each domino is represented by a different English letter (lowercase or uppercase).
  • The j-th character in Si represents the domino that occupies the square at the i-th row from the top and j-th column from the left.

Constraints

  • 1N52
  • |S1|=|S2|=N
  • S1 and S2 consist of lowercase and uppercase English letters.
  • S1 and S2 represent a valid arrangement of dominoes.

Input

Input is given from Standard Input in the following format:

N
S1
S2

Output

Print the number of such ways to paint the dominoes, modulo 1000000007.


Sample Input 1

Copy
3
aab
ccb

Sample Output 1

Copy
6

There are six ways as shown below:


Sample Input 2

Copy
1
Z
Z

Sample Output 2

Copy
3

Note that it is not always necessary to use all the colors.


Sample Input 3

Copy
52
RvvttdWIyyPPQFFZZssffEEkkaSSDKqcibbeYrhAljCCGGJppHHn
RLLwwdWIxxNNQUUXXVVMMooBBaggDKqcimmeYrhAljOOTTJuuzzn

Sample Output 3

Copy
958681902

第一次AK所以内心很激动!!哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈 哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈 哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈 哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈哈
所以也就不解释了你们自己看吧。
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
char s[55],s1[55];
int a[55];
int main()
{
    int n;
    while(cin>>n)
    {
        scanf("%s",&s);
        scanf("%s",&s1);
        int r=0,z;
        long long sum=0;
        for(int i=0;i<n;i++)
        {
            if(s[i]==s[i+1]){i++;a[r++]=2;}
            else a[r++]=1;
        }
        if(a[0]==1){sum=3;z=1;}
        else {sum=6;z=2;}
        for(int i=1;i<r;i++)
        {
            if(a[i]==2)
            {
                if(a[i]==z)
                {
                    sum=sum*3%1000000007;
                }
                else
                {
                    z=a[i];
                    sum=sum*2%1000000007;
                }
            }
            else
            {
                if(a[i]==z)
                {
                    sum=sum*2%1000000007;
                }
                else
                {
                    z=a[i];
                }
            }
        }
        printf("%lld\n",sum);
    }

    return 0;
}




  

猜你喜欢

转载自blog.csdn.net/j1nab1n9/article/details/77434704