1044 火星数字(PAT 乙级 C++实现)

1044 火星数字(20)(20 point(s))

火星人是以13进制计数的:

  • 地球人的0被火星人称为tret。
  • 地球人数字1到12的火星文分别为:jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec。
  • 火星人将进位以后的12个高位数字分别称为:tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou。

例如地球人的数字“29”翻译成火星文就是“hel mar”;而火星文“elo nov”对应地球数字“115”。为了方便交流,请你编写程序实现地球和火星数字之间的互译。

输入格式:

输入第一行给出一个正整数N(<100),随后N行,每行给出一个[0, 169)区间内的数字 —— 或者是地球文,或者是火星文。

输出格式:

对应输入的每一行,在一行中输出翻译后的另一种语言的数字。

输入样例:

4
29
5
elo nov
tam

输出样例:

hel mar
may
115
13

分析:

string 转 int  用 std::string s,然后通过 std::stoi(s) 即可得到整型 int 。

注意与13整除时不要输出 tret 。 

string 复制 substr() 和抹去 erase()

详细代码:

#include <iostream>    
#include <string>
using namespace std;  

string low[] = {"tret","jan","feb","mar","apr","may","jun","jly","aug","sep","oct","nov","dec"};// 下标 0~12
string high[] = {"","tam","hel","maa","huh","tou","kes","hei","elo","syy","lok","mer","jou"};  // 下标 1~12 
	
static int getx(string x,int flag){
	if(flag==0){
		for(int j=0;j<13;++j){
			if(low[j]==x){ 
				return j; 
			}
		}
	}else{
		for(int j=1;j<13;++j){
			if(high[j]==x){ 
				return j; 
			}
		}
	} 
}

// 1044 火星数字(20)(20 point(s))
int main(void){    
	int n; cin>>n; 
	getchar();  // 换行去掉

	for(int i=0;i<n;++i){
		std::string s;  
		getline(cin,s);

		if(s[0]>='0' && s[0]<='9'){ // 数字
			int t = std::stoi(s); 
			if(t<13){
				cout<<low[t]<<endl;
			}else{ 
				if(t%13){ 
					cout<<high[t/13]<<" "<<low[t%13]<<endl;
				}else{
					cout<<high[t/13]<<endl;
				}
			}
		}else{
			if(s.length()==4){
				cout<<"0"<<endl; 
			}else if(s.size()==3){ // 只有一位时 长度不超过4 
				for(int j=0;j<13;++j){
					if(low[j]==s){
						cout<<j<<endl;
						break;
					} 
					if(high[j]==s){ 
						cout<<(13*j)<<endl;
						break;
					}
				} 
			}else{
				string t1 = s.substr(0,3);// 三位
				int x1 = getx(t1,1);
				s.erase(0,4);  
				int x2 = getx(s,0);
				cout<<(13*x1+x2)<<endl;   
			}
		}
	}

	return 0;
}// jinzheng 2018.7.17 20:05

猜你喜欢

转载自blog.csdn.net/guangjinzheng/article/details/81089150