PAT乙级1044 火星数字

1044. 火星数字(20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
8000 B
判题程序
Standard
作者
CHEN, Yue

火星人是以13进制计数的:

  • 地球人的0被火星人称为tret。
  • 地球人数字1到12的火星文分别为:jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec。
  • 火星人将进位以后的12个高位数字分别称为:tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou。

例如地球人的数字“29”翻译成火星文就是“hel mar”;而火星文“elo nov”对应地球数字“115”。为了方便交流,请你编写程序实现地球和火星数字之间的互译。

输入格式:

输入第一行给出一个正整数N(<100),随后N行,每行给出一个[0, 169)区间内的数字 —— 或者是地球文,或者是火星文。

输出格式:

对应输入的每一行,在一行中输出翻译后的另一种语言的数字。

输入样例:
4
29
5
elo nov
tam
输出样例:
hel mar
may
115

13

#include<stdio.h>
#include<string.h>
#define size 20
char digits[][size] = { "tret","jan","feb","mar","apr","may","jun","jly","aug","sep","oct","nov","dec" };
char tens[][size] = { [0]='\0',[1]="tam","hel","maa","huh","tou","kes","hei","elo","syy","lok","mer","jou" };
void marstoearth(char ar[]);
void earthtomars(char ar[]);
int main(void)
{
	int num;
	scanf("%d", &num);
	getchar();
	while (num--)
	{
		char str[size];
		memset(str, 0, sizeof(str));
		gets(str);
		if (str[0] >= '0'&&str[0] <= '9')
		{
			earthtomars(str);
		}
		else
		{
			marstoearth(str);
		}
		printf("\n");
	}
	return 0;
}

void earthtomars(char ar[])
{
	int len = strlen(ar);
	int sum = 0;
	for (int i = len - 1, k = 1; i >= 0; i--, k *= 10)
	{
		sum += (ar[i] - '0')*k;
	}

	//printf("sum=%d", sum);
	if (sum == 0)
	{
		printf("tret");
	}
	else
	{
		int a = sum / 13;//tens
		int b = sum % 13;//digits
		if (a)
		{
			printf("%s", tens[a]);
		}
		if (a&&b)
		{
			printf(" ");
		}
		if (b)
		{
			printf("%s", digits[b]);
		}
	}
}
void marstoearth(char ar[])
{
	int result = 0;
	for (int i = 1; i<13; i++)
	{
		if (strstr(ar, tens[i]) != NULL)
		{
			result += i * 13;
			break;
		}
	}
	for (int i = 0; i<13; i++)
	{
		if (strstr(ar, digits[i]) != NULL)
		{
			result += i;
			break;
		}
	}
	printf("%d", result);
}




猜你喜欢

转载自blog.csdn.net/sinat_37273780/article/details/56489252