1044 火星数字 (C++)

火星人是以 13 进制计数的:

  • 地球人的 0 被火星人称为 tret。
  • 地球人数字 1 到 12 的火星文分别为:jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec。
  • 火星人将进位以后的 12 个高位数字分别称为:tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou。

例如地球人的数字 29 翻译成火星文就是 hel mar;而火星文 elo nov 对应地球数字 115。为了方便交流,请你编写程序实现地球和火星数字之间的互译。

输入格式:

输入第一行给出一个正整数 N(<100),随后 N 行,每行给出一个 [0, 169) 区间内的数字 —— 或者是地球文,或者是火星文。

输出格式:

对应输入的每一行,在一行中输出翻译后的另一种语言的数字。

输入样例:

4
29
5
elo nov
tam

结尾无空行

输出样例:

hel mar
may
115
13

结尾无空行

代码:

#include <iostream>
#include <string>
#include <map>
#include <vector>
#include <sstream>

using namespace std;

string high[12] = {"tam", "hel", "maa", "huh", "tou", "kes", "hei", "elo", "syy", "lok", "mer", "jou"}; 
string low[13] = {"tret", "jan", "feb", "mar", "apr", "may", "jun", "jly", "aug", "sep", "oct", "nov", "dec"};// 0->12
map<string, int> map_high;
map<string, int> map_low;

vector<string> split(string &s, char delim) {
    stringstream stringstream1(s);
    string tmp;
    vector<string> v;
    while (getline(stringstream1, tmp, delim)) {
        v.push_back(tmp);
    }
    return v;
}

int MarToEarth(string &tmp) {
    vector<string> v = split(tmp, ' ');

    if (v.size() == 1) {
        auto pos = map_high.find(v.at(0));
        if (pos == map_high.end()) {
            return map_low.at(v.at(0));
        } else {
            return (*pos).second * 13;
        }
    } else {
        return map_high.at(v.at(0)) * 13 + map_low.at(v.at(1));
    }
}

string EarthToMar(string &num) {
    int N = atoi(num.c_str());
    int a = N / 13;
    int b = N % 13;
    if (b == 0) {
        if (a == 0) {
            return low[0];
        } else {
            return high[a - 1];
        }
    } else {
        if (a == 0) {
            return low[b];
        } else {
            return high[a - 1] + " " + low[b];
        }
    }
}


int main(int argc, char *argv[]) {

    for (int i = 0; i < 12; ++i) {
        map_high[high[i]] = i + 1;
    }
    for (int i = 0; i < 13; ++i) {
        map_low[low[i]] = i;
    }


    int N;
    scanf("%d", &N);
    getchar();
    vector<string> NUM;
    vector<string> v;
    string tmp;
    for (int i = 0; i < N; ++i) {
        getline(cin, tmp);
        NUM.push_back(tmp);
    }

    int ret1;
    string ret2;
    for (int i = 0; i < N; ++i) {
        tmp = NUM[i];
        if (tmp[0] >= 'a' && tmp[0] <= 'z') {
            ret1 = MarToEarth(tmp);
            printf("%d\n", ret1);
        } else {
            ret2 = EarthToMar(tmp);
            cout << ret2 << endl;
        }
    }

    return 0;
}


猜你喜欢

转载自blog.csdn.net/qq_40748967/article/details/121243868
今日推荐