PAT乙级刷题之路1044 火星数字 (20分)

1044 火星数字 (20分)

火星人是以 13 进制计数的:
地球人的 0 被火星人称为 tret。
地球人数字 1 到 12 的火星文分别为:jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec。
火星人将进位以后的 12 个高位数字分别称为:tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou。
例如地球人的数字 29 翻译成火星文就是 hel mar;而火星文 elo nov 对应地球数字 115。为了方便交流,请你编写程序实现地球和火星数字之间的互译。
输入格式:
输入第一行给出一个正整数 N(<100),随后 N 行,每行给出一个 [0, 169) 区间内的数字 —— 或者是地球文,或者是火星文。
输出格式:
对应输入的每一行,在一行中输出翻译后的另一种语言的数字。
输入样例:
4
29
5
elo nov
tam
输出样例:
hel mar
may
115
13

#include <iostream>
#include <string>
using namespace std;
string a[13] = {"tret", "jan", "feb", "mar", "apr", "may", "jun", "jly", "aug", "sep", "oct", "nov", "dec"};
string b[13] = {"####", "tam", "hel", "maa", "huh", "tou", "kes", "hei", "elo", "syy", "lok", "mer", "jou"};
string s;
int len;

void func1(int t) //地球人的数字翻译成火星文
{    
	if (t / 13) cout << b[t / 13];    
	if ((t / 13) && (t % 13)) cout << " ";    
	if (t % 13 || t == 0) cout << a[t % 13];
}

void func2() //火星文翻译成地球数字
{    
	int t1 = 0, t2 = 0;    
	string s1 = s.substr(0, 3), s2;    
	if (len > 4) s2 = s.substr(4, 3);   
	for (int j = 1; j <= 12; j++) {        
		if (s1 == a[j] || s2 == a[j]) t2 = j;        
		if (s1 == b[j]) t1 = j;    
	}    
	cout << t1 * 13 + t2;
}

int main() 
{    
	int n;    
	cin >> n;   
	getchar();   
	for (int i = 0; i < n; i++) {        
		getline(cin, s);        
		len = s.length();        
		if (s[0] >= '0' && s[0] <= '9')            
			func1(stoi(s));        
		else            
			func2();        
		cout << endl;    
	}    
	return 0;
}

发布了73 篇原创文章 · 获赞 0 · 访问量 545

猜你喜欢

转载自blog.csdn.net/derbi123123/article/details/103780292