PAT乙级—1044 火星数字 (20分)

火星人是以 13 进制计数的:
地球人的 0 被火星人称为 tret。
地球人数字 1 到 12 的火星文分别为:jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec。
火星人将进位以后的 12 个高位数字分别称为:tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou。
例如地球人的数字 29 翻译成火星文就是 hel mar;而火星文 elo nov 对应地球数字 115。为了方便交流,请你编写程序实现地球和火星数字之间的互译。
输入格式:
输入第一行给出一个正整数 N(<100),随后 N 行,每行给出一个 [0, 169) 区间内的数字 —— 或者是地球文,或者是火星文。
输出格式:
对应输入的每一行,在一行中输出翻译后的另一种语言的数字。

输入样例:
4
29
5
elo nov
tam
输出样例:
hel mar
may
115
13

思路:
  读取每一行,根据首字母是否为数字判断为地球语还是火星语。后面根据除法和取余来计算即可。

注意:
  注意输出火星语时的三种情况,只有进位,二者都有,只有个位

代码:(C++)

#include<iostream>
#include<sstream>

using namespace std;

int main()
{
    string str1[13] = {"tret","jan", "feb", "mar", "apr", "may", "jun", "jly", "aug", "sep", "oct", "nov", "dec"};
    string str2[13] = {" ","tam", "hel", "maa", "huh", "tou", "kes", "hei", "elo", "syy", "lok", "mer", "jou"};
    int n;
    string p;
    stringstream ss;
    getline(cin,p);
    ss<<p;
    ss>>n;
    ss.clear();
    
    for(int i=0; i<n; i++)
    {
        string number;
        getline(cin,number);
        if(number[0]>='0' && number[0]<='9')//判断首字符就可以判断是数字还是字母
        {
            int e,he;
            ss<<number;
            ss>>e;
            ss.clear();
            he = e/13;
            e = e%13;
            if(he!=0 && e==0)
                cout<<str2[he]<<endl;
            else if(he!=0 && e!=0)
                cout<<str2[he]<<' '<<str1[e]<<endl;
            else
                cout<<str1[e]<<endl;
        }
        else
        {
            int site = number.find(' ');
            int m=0;
            for(int i=1; i<13; i++)
            {
                if(number.substr(0,site) == str2[i])
                {
                    m = i*13;
                    break;
                }
            }
            for(int i=0; i<13; i++)
            {
                if(number.substr(site+1) == str1[i])
                {
                    m +=i;
                    break;
                }
            }
            cout<<m<<endl;
        }
        
    }
    return 0;
}
发布了77 篇原创文章 · 获赞 20 · 访问量 5783

猜你喜欢

转载自blog.csdn.net/qq_42396168/article/details/104995036