HDU-1010-Tempter of the Bone(dfs)

Tempter of the Bone


Problem Description:
The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.
The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.
Input:
The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:
'X': a block of wall, which the doggie cannot enter; 
'S': the start point of the doggie; 
'D': the Door; or
'.': an empty block.
The input is terminated with three 0's. This test case is not to be processed.
Output:
For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.
Sample Input:
4 4 5
S.X.
..X.
..XD
....
3 4 5
S.X.
..X.
...D
0 0 0
Sample Output:
NO

YES

解题思路:

这个题是让你在规定的步数找到出口D,做这个题的时候刚开始是直接暴力搜的,后来提交超时了,然后就加了个判断条件,就是如果找到了出口就不再往后找了。

程序代码:

#include<stdio.h>
#include<string.h>
void Dfs(int x,int y,int step);
int m,n,t,flag;
char a[8][8];
int book[8][8];
int main()
{
	int i,j;
	while(scanf("%d%d%d",&m,&n,&t)!=EOF)
	{
		memset(book,0,sizeof(book));
		flag=0;
		getchar();
		if(m==0&&n==0&&t==0)
			break;
		for(i=0;i<m;i++)
		{
			for(j=0;j<n;j++)
				scanf("%c",&a[i][j]);
			getchar();
		}
		for(i=0;i<m;i++)
			for(j=0;j<n;j++)
				if(a[i][j]=='S')
				{
					Dfs(i,j,0);
					book[i][j]=1;
					break;
				}
		if(flag==1)
			printf("YES\n");
		else
			printf("NO\n");	
	}
    return 0;
}
void Dfs(int x,int y,int step)
{
	if(flag==1)
		return;
	int tx,ty,i,j,k;
	int next[4][2]={0,1, 1,0, 0,-1, -1,0};
	if(a[x][y]=='D')
	{
		if(step==t)
			flag=1;
		return;
	}
	for(k=0;k<4;k++)
	{
		tx=x+next[k][0];
		ty=y+next[k][1];
		if(tx<0||tx>=m||ty<0||ty>=n)
			continue;
		if((a[tx][ty]=='.'||a[tx][ty]=='D')&&book[tx][ty]==0)
		{
			book[tx][ty]=1;
			Dfs(tx,ty,step+1);
			book[tx][ty]=0;
		}
	}
	return;
}

猜你喜欢

转载自blog.csdn.net/hezhiying_/article/details/81052956