PAT A 1015 Reversible Primes

A reversible prime in any number system is a prime whose “reverse” in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (< 10^5^) and D (1 < D <= 10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line “Yes” if N is a reversible prime with radix D, or “No” if not.

Sample Input:

73 10
23 2
23 10
-2

Sample Output:

Yes
Yes
No

题目的意思是n是十进制,在d进制下反转,再转换为十进制,是不是素数。

#include<cstdio>
#include<cmath>

const int maxn = 10010;

int reverse(int n,int d) {
    int digit[maxn], len = 0;
    do {        //将十进制转换为其他进制,除基取余法,存在数组里,原数正好是倒的,低位在前,高位在后。等于就是反转后的数。。。(高位是0,低位是len-1)
        digit[len++] = n % d;
        n /= d;
    } while (n);
    int ans = 0, radix = 1;
    for (int i = len-1; i >= 0; i--) {//因为低位在len-1,所以从后面开始累乘
        ans += digit[i] * radix;
        radix *= d;
    }
    return ans;
}

bool isPrime(int a) {
    if (a <= 1) return false;
    int sqr = (int)sqrt(a);
    for (int i = 2; i <= sqr; i++) {
        if (a % i == 0) return false;
    }
    return true;
}

int main() {
    int n, d;
    while (scanf("%d",&n)!=EOF) {
        if (n < 0) break;
        scanf("%d", &d);
        if (isPrime(n) == false) printf("No\n");
        else {
            if (isPrime(reverse(n, d)) == false) printf("No\n");
            else printf("Yes\n");
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/joah_ge/article/details/81065151
今日推荐