HDU - 2391 Filthy Rich

They say that in Phrygia, the streets are paved with gold. You’re currently on vacation in Phrygia, and to your astonishment you discover that this is to be taken literally: small heaps of gold are distributed throughout the city. On a certain day, the Phrygians even allow all the tourists to collect as much gold as they can in a limited rectangular area. As it happens, this day is tomorrow, and you decide to become filthy rich on this day. All the other tourists decided the same however, so it’s going to get crowded. Thus, you only have one chance to cross the field. What is the best way to do so?

Given a rectangular map and amounts of gold on every field, determine the maximum amount of gold you can collect when starting in the upper left corner of the map and moving to the adjacent field in the east, south, or south-east in each step, until you end up in the lower right corner.

Input

The input starts with a line containing a single integer, the number of test cases.
Each test case starts with a line, containing the two integers r and c, separated by a space (1 <= r, c <= 1000). This line is followed by r rows, each containing c many integers, separated by a space. These integers tell you how much gold is on each field. The amount of gold never negative.
The maximum amount of gold will always fit in an int.

Output

For each test case, write a line containing “Scenario #i:”, where i is the number of the test case, followed by a line containing the maximum amount of gold you can collect in this test case. Finish each test case with an empty line.

Sample Input

1
3 4
1 10 8 8
0 0 1 8
0 27 0 4

Sample Output

Scenario #1:
42

题解:斜着走黄金肯定是最少的,所以只需比较左,上两个方向的大小,每次都选择最大的。

贴代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int mp[1010][1010];
int main()
{
    int n,o=1;
    scanf("%d",&n);
    while(n--)
    {
        int i,j,r,c;
        memset(mp,0,sizeof(mp));
        scanf("%d%d",&r,&c);
        for(i=1; i<=r; i++)
            for(j=1; j<=c; j++)
                scanf("%d",&mp[i][j]);
        for(i=1; i<=r; i++)
            for(j=1; j<=c; j++)
                mp[i][j]+=max(mp[i][j-1],mp[i-1][j]);
        printf("Scenario #%d:\n",o++);
        printf("%d\n",mp[r][c]);
        printf("\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/gjlfly/article/details/81110268
今日推荐