N - Filthy Rich

题目:

They say that in Phrygia, the streets are paved with gold. You’re currently on vacation in Phrygia, and to your astonishment you discover that this is to be taken literally: small heaps of gold are distributed throughout the city. On a certain day, the Phrygians even allow all the tourists to collect as much gold as they can in a limited rectangular area. As it happens, this day is tomorrow, and you decide to become filthy rich on this day. All the other tourists decided the same however, so it’s going to get crowded. Thus, you only have one chance to cross the field. What is the best way to do so? 

Given a rectangular map and amounts of gold on every field, determine the maximum amount of gold you can collect when starting in the upper left corner of the map and moving to the adjacent field in the east, south, or south-east in each step, until you end up in the lower right corner. 

Input

The input starts with a line containing a single integer, the number of test cases. 
Each test case starts with a line, containing the two integers r and c, separated by a space (1 <= r, c <= 1000). This line is followed by r rows, each containing c many integers, separated by a space. These integers tell you how much gold is on each field. The amount of gold never negative. 
The maximum amount of gold will always fit in an int.

Output

For each test case, write a line containing “Scenario #i:”, where i is the number of the test case, followed by a line containing the maximum amount of gold you can collect in this test case. Finish each test case with an empty line. 

Sample Input

1
3 4
1 10 8 8
0 0 1 8
0 27 0 4

Sample Output

Scenario #1:
42

题意:

在矩阵中,从左上角走到右下角,矩阵中的数字代表金币,要你求出你最多可以收集到的金币数。

思路:

这道题是一道dp题,所以要想求出最大的值,就从这个位置的找到来到这个位置的两个位置,从这两个位置中挑选一个最大值作为现在位置的上一个位置,把和记录下来,一直找到zuos左上角,就得到了答案。

代码如下:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

int t,n,m;
int map[1001][1001];

int main()
{
    scanf("%d",&t);
    int kk=1;
    while(t--)
    {
        scanf("%d%d",&n,&m);
        int i,j;
        memset(map,0,sizeof map);
        for(i=1;i<=n;i++)
        {
            for(j=1;j<=m;j++)
            {
                scanf("%d",&map[i][j]);
                map[i][j]+=max(map[i-1][j],map[i][j-1]);
            }
        }
        printf("Scenario #%d:\n%d\n",kk++,map[n][m]);
        printf("\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/titi2018815/article/details/81111318