dp---hdu-2391-Filthy Rich

Filthy Rich

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4079    Accepted Submission(s): 1793


 

Problem Description

They say that in Phrygia, the streets are paved with gold. You’re currently on vacation in Phrygia, and to your astonishment you discover that this is to be taken literally: small heaps of gold are distributed throughout the city. On a certain day, the Phrygians even allow all the tourists to collect as much gold as they can in a limited rectangular area. As it happens, this day is tomorrow, and you decide to become filthy rich on this day. All the other tourists decided the same however, so it’s going to get crowded. Thus, you only have one chance to cross the field. What is the best way to do so?

Given a rectangular map and amounts of gold on every field, determine the maximum amount of gold you can collect when starting in the upper left corner of the map and moving to the adjacent field in the east, south, or south-east in each step, until you end up in the lower right corner.

 

Input

The input starts with a line containing a single integer, the number of test cases.
Each test case starts with a line, containing the two integers r and c, separated by a space (1 <= r, c <= 1000). This line is followed by r rows, each containing c many integers, separated by a space. These integers tell you how much gold is on each field. The amount of gold never negative.
The maximum amount of gold will always fit in an int.

 

Output

For each test case, write a line containing “Scenario #i:”, where i is the number of the test case, followed by a line containing the maximum amount of gold you can collect in this test case. Finish each test case with an empty line.

 

Sample Input

1

3   4

1   10   8   8

0    0    1   8

0   27   0   4

Sample Output

Scenario #1:

42

Source

HDU 2008-10 Public Contest

Recommend

lcy   |   We have carefully selected several similar problems for you:  2393 2388 2389 2386 2390

题解:简单DP

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int dp[1005][1005],s[1005][1005];
int main(){
	int t,n,m;
	scanf("%d",&t);
	for(int o=1;o<=t;o++){
		scanf("%d %d",&n,&m);
		for(int i=1;i<=n;i++){
			for(int j=1;j<=m;j++){
				scanf("%d",&s[i][j]);
			}
		}
		memset(dp,0,sizeof(dp));
		for(int i=1;i<=n;i++){
			for(int j=1;j<=m;j++){
				dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
				dp[i][j]+=s[i][j];
			}
		}
		printf("Scenario #%d:\n",o);
		printf("%d\n\n",dp[n][m]);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/black_horse2018/article/details/81149289
今日推荐