PAT-1015 Reversible Primes

A reversible prime in any number system is a prime whose “reverse” in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (<105) and D (1<D≤10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line Yes if N is a reversible prime with radix D, or No if not.

Sample Input:

73 10
23 2
23 10
-2

Sample Output:

Yes
Yes
No

思路

先判断n是不是素数,然后将n转化为d进制的数,在把这个数翻转,然后在从d进制转化为10进制数,然后在判断是不是素数。

Code

#include <iostream>
#include <math.h>
using namespace std;

// 将n转化为d进制(1<=d<=10)的数
// 将d进制的数进行翻转
string convert_to_d_radix(int n, int radix)
{
    
     // 10进制转换为d进制
    string temp = "";
    while (n != 0)
    {
    
    
        int mod = n % radix;
        temp += to_string(mod);
        n = n / radix;
    }
    return temp;
}

// 将翻转得到的数转换为10机制
int convert(string n, int radix)
{
    
     //d进制转换为10进制
    int sum = 0;
    int index = 0;
    for (int i = n.size() - 1; i >= 0; i--)
    {
    
    
        int temp = n[i] - '0';
        sum += temp * pow(radix, index++);
    }
    return sum;
}
// 判断10进制的数是不是素数
bool is_prime(int n)
{
    
    
    if (n == 1)
        return false; // 1不是素数
    for (int i = 2; i <= sqrt(n); i++)
    {
    
    
        if (n % i == 0)
        {
    
    
            return false; // 不是素数
        }
    }
    return true;
}
int main()
{
    
    
    int d;
    int n;

    cin >> n;
    while (n >= 0)
    {
    
    
        cin >> d;
        if (is_prime(n))
        {
    
    
            if (is_prime(convert(convert_to_d_radix(n, d), d)))
            {
    
    
                cout << "Yes" << endl;
            }
            else
            {
    
    
                cout << "No" << endl;
            }
        }
        else
        {
    
    
            cout << "No" << endl;
        }
        cin >> n;
    }

    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_42100456/article/details/108939576
今日推荐