1078 Hashing (25 分)

1078 Hashing (25 分)

The task of this problem is simple: insert a sequence of distinct positive integers into a hash table, and output the positions of the input numbers. The hash function is defined to be H(key)=key%TSize where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive numbers: MSize (≤10​4​​) and N (≤MSize) which are the user-defined table size and the number of input numbers, respectively. Then N distinct positive integers are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the corresponding positions (index starts from 0) of the input numbers in one line. All the numbers in a line are separated by a space, and there must be no extra space at the end of the line. In case it is impossible to insert the number, print "-" instead.

Sample Input:

4 4
10 6 4 15

Sample Output:

0 1 4 -

 具体为二次探测法的实现,这里素数的判断要求并不是很高,所以直接一次向下计算就好,如果时间要求非常高的话,可以先将素数列表打表全部列出来,然后使用lower_bound在数组中求解就好,或者使用快速求解素数的算法也可以

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <stack>
#include <queue>
#include <map>
#include <cmath>

using namespace std;
typedef long long ll;
const int mod = 1e9+7;
const int maxn = 1e4+1000;
int m,n;
int a[maxn],pos[maxn];
bool flag[maxn*maxn];

bool is_prime(int x)
{
    if(x == 1) return false;
    for(int i = 2;i*i <= x;i ++)
        if(x % i == 0)
            return false;
    return true;
}
int main()
{
    scanf("%d%d",&m,&n);
    for(int i = 0;i < n;i++)
        scanf("%d",a+i);

    while(!is_prime(m)) m++;

//    cout << m <<endl;
    int num;
    for(int i =0 ;i < n;i ++)
    {
        num = 0;
        int _pos = a[i] % m;
        while(true)
        {
            if(num == m) {
                pos[i] = -1;
                break;
            }
            if(!flag[(_pos+num*num)%m]){
                flag[(_pos+num*num)%m] = true,pos[i] = (_pos+num*num) % m;
                break;
            }
            else num++;
        }
    }

    bool first = false;
    for(int i = 0;i < n;i ++)
        if(!first){
            first = true;
            if(pos[i] == -1)
                printf("-");
            else
                printf("%d",pos[i]);
        }
        else{
             if(pos[i] == -1)
                printf(" -");
            else
                printf(" %d",pos[i]);
        }
    printf("\n");
    return 0;
}

猜你喜欢

转载自blog.csdn.net/li1615882553/article/details/84452396