【笨方法学PAT】1078 Hashing (25 分)

版权声明:欢迎转载,请注明来源 https://blog.csdn.net/linghugoolge/article/details/84649140

一、题目

The task of this problem is simple: insert a sequence of distinct positive integers into a hash table, and output the positions of the input numbers. The hash function is defined to be H(key)=key%TSize where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive numbers: MSize (≤10​4​​) and N (≤MSize) which are the user-defined table size and the number of input numbers, respectively. Then N distinct positive integers are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the corresponding positions (index starts from 0) of the input numbers in one line. All the numbers in a line are separated by a space, and there must be no extra space at the end of the line. In case it is impossible to insert the number, print "-" instead.

Sample Input:

4 4
10 6 4 15

Sample Output:

0 1 4 -

二、题目大意

二次探方插入。

三、考点

hash

四、注意

1、探方:k = (a + j * j) % m;

2、【注意】1不是素数,否则3分过不去

五、代码

#include<iostream>
#include<vector>
using namespace std;

bool isPrime(int n) {
	if (n == 1)
		return false;
	if (n == 2 || n == 3)
		return true;
	for (int i = 2; i*i <= n; ++i) {
		if (n%i == 0)
			return false;
	}
	return true;
}

int main() {
	//read
	int m, n;
	cin >> m >> n;

	//get prime number
	while (!isPrime(m))
		m++;

	vector<int> hash(m,-1);
	for (int i = 0; i < n; ++i) {
		int a;
		cin >> a;

		//find hash
		int k;
		bool flag = false;
		for (int j = 0; j < m; ++j) {
			k = (a + j * j) % m;
			if (hash[k] == -1) {
				hash[k] = a;
				flag = true;
				break;
			}
		}

		//judge space
		if (i != 0)
			cout << " ";

		//judge hash
		if (flag == true) 
			cout << k;
		else
			cout << "-";
	}

	system("pause");
	return 0;
}

猜你喜欢

转载自blog.csdn.net/linghugoolge/article/details/84649140