POJ-3461 Oulipo (经典) kmp ʕ •ᴥ•ʔ

Oulipo

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 49354   Accepted: 19605

Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

  • One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
  • One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output

1
3
0

题意:给你两个串子,第一为模板串 第二为子串 求子串中有多少个模板串

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cmath>
#include<cstring>
#include<vector>
#include<queue>
#define ll long long
using namespace std;
string s,ss;
int ans;
int nexxt[1000010];
void getnext()
{
	int j=-1,i=0;
	nexxt[0]=-1;
	while(i<ss.size())
	{
		if(j==-1||ss[i]==ss[j])
		{
			i++,j++;
			nexxt[i]=j;
		}
		else
		j=nexxt[j];
	}
        //  A B C A B D
        // -1 0 0 0 1 2 0  nexxt数组的值 
        
     
}
void kmp()
{
	getnext();// 计算出nexxt数组的值  nexxt 也可以求循环串 
	int i=0,j=0;
	while(i<s.size())
	{
		if(s[i]==ss[j]||j==-1)
		{
			i++,j++;//值一样 跳过
		}
		else
			j=nexxt[j];// 看图
		if(j==ss.size())
		{
			ans++;
		}
	}

}
int main()
{
	ios::sync_with_stdio(false);
	int t;
	cin>>t;
	while(t--)
	{
		ans=0;
		cin>>ss>>s;
		kmp();
		cout<<ans<<endl;
	}
	return 0;
}

 A B A B

-1 0 0 1 nexxt值

j=nexxt[j]=1;

所以就是下图这样

猜你喜欢

转载自blog.csdn.net/henucm/article/details/81869812
今日推荐