hdu 简单DP 1003 Super Jumping! Jumping! Jumping!

Super Jumping! Jumping! Jumping!

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 88   Accepted Submission(s) : 33

Font: Times New Roman | Verdana | Georgia

Font Size:  

Problem Description

Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.



The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.
Your task is to output the maximum value according to the given chessmen list.

Input

Input contains multiple test cases. Each test case is described in a line as follow:
N value_1 value_2 …value_N 
It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.
A test case starting with 0 terminates the input and this test case is not to be processed.

Output

For each case, print the maximum according to rules, and one line one case.

Sample Input

3 1 3 2
4 1 2 3 4
4 3 3 2 1
0

Sample Output

4
10
3

Author

lcy

#include <bits/stdc++.h>
using namespace std;
int a[1005];
long long dp[1005];
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        if(n==0) break;
        for(int i=1; i<=n; i++)
            scanf("%d",&a[i]);
        a[0]=0,dp[0]=0; //为每一次dp的比较增加一步与0的比较
        long long ans=-1;
        for(int i=1; i<=n; i++)
        {
            dp[i]=-1;//让每一次的dp初始为-1,这样可以进行与dp[0]的比较
            for(int j=0; j<i; j++)
            {
                if(a[i]>a[j])
                    dp[i]=max(dp[i],dp[j]);//每个a[i]与前面的dp进行比较,每一个dp存的是当前最长递增子序列之和
            }
            dp[i]+=a[i]; //找完所有比自己小的,加上自己
            ans=max(ans,dp[i]);//更新答案
        }
        printf("%lld\n",ans);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41037114/article/details/80980848