[最小生成树] Constructing Roads HDU图论03 1001

Constructing Roads

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 27   Accepted Submission(s) : 17

Font: Times New Roman | Verdana | Georgia

Font Size:  

Problem Description

There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected. 

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

Input

The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

Output

You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum. 

Sample Input

3
0 990 692
990 0 179
692 179 0
1
1 2

Sample Output

179

Source

kicc




#include <bits/stdc++.h>
using namespace std;

const int mn = 105;
const int mq = mn * (mn + 1) / 2;

int n;
struct node
{
	int x, y, z;
} e[mq];
bool cmp(const node& a, const node& b)
{
	return a.z < b.z;
}

int p[mn];
int Find(int x)
{
	if (p[x] == x)
		return x;
	return p[x] = Find(p[x]);
}

int main()
{
	while (~scanf("%d", &n))
	{
		for (int i = 1; i <= n; i++)
			p[i] = i;

		int ans = 0;
		for (int i = 1; i <= n; i++)
		{
			for (int j = 1; j <= n; j++)
			{
				int s;
				scanf("%d", &s);
				if (j > i)
				{
					e[ans].x = i;
					e[ans].y = j;
					e[ans].z = s;
					ans++;
				}
			}
		}

		int q;
		scanf("%d", &q);
		int sz = 0;
		for (int i = 1; i <= q; i++)
		{
			int a, b;
			scanf("%d %d", &a, &b);
			int pa = Find(a);
			int pb = Find(b);
			if (pa != pb)
			{
				p[pa] = pb;
				sz++;
			}
		}

		sort(e, e + ans, cmp);

		int sum = 0;
		for (int i = 0; i < ans; i++)
		{
			int fx = Find(e[i].x);
			int fy = Find(e[i].y);
			if (fx != fy)
			{
				p[fx] = fy;
				sum += e[i].z;
				sz ++;
				if (sz == n - 1)
					break;
			}
		}
		printf("%d\n", sum);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/ummmmm/article/details/80636713