HDU - 1102 Constructing Roads (最小生成树)

Constructing Roads

原题链接:http://acm.hdu.edu.cn/showproblem.php?pid=1102


There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected.

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

Input

The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

Output

You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.

Sample Input

3
0 990 692
990 0 179
692 179 0
1
1 2

Sample Output

179

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
struct edge{
    int u,v;
    int dis;
}p[10010];
bool cmp(edge x,edge y)
{
    return x.dis<y.dis;
}//
int n,m,l,f[110];
int Find(int x)
{
    if(x!=f[x]) return f[x]=Find(f[x]);
    else return x;
}
void Union(int x,int y)
{
    int u=Find(x);
    int v=Find(y);
    if(u!=v) f[u]=v;
}
int main()
{
    std::ios::sync_with_stdio(false);
    while(cin>>n)
    {
        int a,b,ans=0,z=n*(n-1)/2;
        l=1;
        for(int i=1;i<=n;i++) f[i]=i;
        memset(p,0,sizeof(p));
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                cin>>a;
                if(j>i)
                {
                    p[l].u=i;
                    p[l].v=j;
                    p[l].dis=a;
                    l++;
                }
            }
        }
        cin>>m;
        for(int i=1;i<=m;i++)
        {
            cin>>a>>b;
            Union(a,b);
        }

        sort(p+1,p+z+1,cmp);
        for(int i=1;i<=z;i++)
        {
            int x=Find(p[i].u);
            int y=Find(p[i].v);

            if(x==y)continue;
            Union(p[i].u,p[i].v);
            ans+=p[i].dis;
        }
        cout<<ans<<endl;
    }
    return 0;
}

就是创建个结构体来储存边,然后把这个结构体数组排序,之后通过并查集把没有归入的最短边加入到图之中。

猜你喜欢

转载自blog.csdn.net/j1nab1n9/article/details/80454102