Constructing Roads--最小生成树

                               Constructing Roads
             Time Limit: 2000MS	 	Memory Limit: 65536K
            Total Submissions: 22124	 	Accepted: 9431

Description

There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected.

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.
Input

The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.
Output

You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.
Sample Input

3
0 990 692
990 0 179
692 179 0
1
1 2
Sample Output

179

描述:

有n个村庄,编号为1 ,2 ,3 ,,,n 应该建造道路使他们互相可达

对输入数据

3
0 990 692
990 0 179
692 179 0
1
1 2
意思有3个村庄,
0 990 692
990 0 179
692 179 0
意思是1号到1,2,3的距离分别为0 990 692
1
1 2
意思是有一条道路已经接通,就是1号与2号间的道路

#include<iostream>
#include<algorithm>
using namespace std;
int per[10005],n,kase,cnt;
struct road
{
    int a,b;
    int len;
}x[10005];
void init()
{
    for(int i=1;i<=n;++i)//初始化 
    {
        per[i]=i;
    }
}
int find(int x)
{
    int r=x;
    while(r!=per[r])//找根节点 
    {
        r=per[r];
    }
    int i=x,j;
    while(i!=r)//压缩路径 
    {
        j=per[i];per[i]=r;i=j;
    }
    return r;
}
void join(int x,int y)
{
    int fx=find(x),fy=find(y);
    if(fx!=fy)//可以合并 
    {
        per[fy]=fx;//合并 
        ++cnt;kase=1;//边数+1,标记状态 
    }
}
int cmp(road a,road b)
{
    return a.len<b.len;//距离由小到大排序 
}
int main()
{
    int a,b,i,j,c,sum;
    while(~scanf("%d",&n))
    {
        init();cnt=c=0;//初始化 
        for(i=0;i<n;++i)
        {
        	for(j=0;j<n;++j)
        	{
        		scanf("%d",&a);
        		if(i!=j)
        		{
        			x[c].a=i+1;x[c].b=j+1;
        			x[c].len=a;
        			++c;
				}
			}
        }
        int m,sum=0;
        scanf("%d",&m);
        for(i=0;i<m;++i)
        {
        	scanf("%d%d",&a,&b);
        	join(a,b);
		}
		sort(x,x+c,cmp);//按路径长短排序
        for(i=0;cnt<n-1;++i)//遍历 
        {
            kase=0;
            join(x[i].a,x[i].b);//否则合并 
            if(kase)//如果成功合并
            {
                sum+=x[i].len;//长度累加 
            }
        }
        printf("%d\n",sum);
    }
    return 0;
}


猜你喜欢

转载自blog.csdn.net/weixin_43965640/article/details/87519828