POJ 2421 Constructing Roads(最小生成树)

Description

There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected.
We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

Input

The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.
Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

Output

You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.

Sample Input

3
0 990 692
990 0 179
692 179 0
1
1 2


Sample Output

179

题解:把i,j值记录到结构体中的x,y 然后输入的值为修路的权值,然后进行最小生成树的裸题了

注意!注意!注意!

这个题多组输入,不然会WA

代码如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
using namespace std;
struct node
{
    int x,y;
    int val;
}road[10000005];
int pre[10000005];
int find(int x)
{
    if(x==pre[x])
    return x;
    else
    {
        return pre[x]=find(pre[x]);
    }
}
bool merge(int x,int y)
{
    int fx=find(x);
    int fy=find(y);
    if(fx!=fy)
    {
        pre[fx]=fy;
        return true;
    }
    else
    {
        return false;
    }
}
bool cmp(node x,node y)
{
    return x.val<y.val;
}
int main()
{
    int n;
     
    while(scanf("%d",&n)!=EOF)
    {
    
    for(int t=1;t<=n;t++)
    {
        pre[t]=t;
    }
    int dis;
    int s=1;
    for(int t=1;t<=n;t++)
    {
        for(int j=1;j<=n;j++)
        {
            scanf("%d",&dis);
            if(j>t)
            {
                road[s].x=t;
                road[s].y=j;
                road[s].val=dis;
                s++;
            }
            
        }
    }
    sort(road+1,road+s+1,cmp);
    int q;
    scanf("%d",&q);
    int fx,fy;
    int cnt=0;
    for(int t=1;t<=q;t++)
    {
        scanf("%d%d",&fx,&fy);
        if(merge(fx,fy))
        {
            cnt++;
        }
    }
    long long int sum=0;
    for(int t=1;t<=s;t++)
    {
        if(cnt==n-1)
        break;
        if(merge(road[t].x,road[t].y))
        {
            cnt++;
            sum+=road[t].val;
        }
    }
    printf("%lld\n",sum);
}
    return 0;
}

猜你喜欢

转载自blog.csdn.net/lbperfect123/article/details/84076358