HDU1102 Constructing Roads(最小生成树prim算法)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/qq_42391248/article/details/82118485

Constructing Roads

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 28801    Accepted Submission(s): 10978

Problem Description

There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected.

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

Input

The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.
Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

Output

You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.

Sample Input

3
0 990 692
990 0 179
692 179 0
1
1 2

Sample Output

179

题意:给出N,然后是N*N的矩阵,表示i到j的距离。,然后给出Q,给出Q行,每行两个数i,j,表示i到j已经通路了。

题解:最小生成树的模板题,直接套算法就写出来了。唯一不同的是有点路通了,把已经通的路权值改成0就行了。

具体代码如下:

#include<iostream>
#include<cstring>
using namespace std;
int map[105][105];
int d[105];
int visit[105];
const int INF=1<<30;
int main()
{
	int n;
	while(cin>>n)
	{
		int i,j;
		memset(visit,1,sizeof(visit));
		memset(d,0,sizeof(d));
		for(i=0;i<n;i++)
			for(j=0;j<n;j++)
				cin>>map[i][j];				
		int m;
		cin>>m;
		for(i=0;i<m;i++)
		{
			int a,b;
			cin>>a>>b;
			map[a-1][b-1]=map[b-1][a-1]=0;//把已经通的路权值改成0 
		}
		for(i=0;i<n;i++)
			d[i]=map[i][0];
		int sum=0;
		visit[0]=0;
		for(i=0;i<n;i++)
		{
			int minn=INF;
			int temp;
			for(j=0;j<n;j++)
				if(visit[j]&&d[j]<minn)
				{
					minn=d[j];
					temp=j;
				}
			if(minn==INF)
				break;
			sum+=minn;
			visit[temp]=0;
			for(j=0;j<n;j++)
				if(visit[j]&&d[j]>map[j][temp])
					d[j]=map[j][temp];			
		}
		cout<<sum<<endl;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_42391248/article/details/82118485