POJ 2421 Constructing Roads(最小生成树)

Constructing Roads
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 30840 Accepted: 13746
Description
There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected.

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.
Input
The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.
Output
You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.
Sample Input
3
0 990 692
990 0 179
692 179 0
1
1 2

Sample Output
179

prim算法

#include<bits/stdc++.h>
using namespace std;
const int N=110;
const int INF=0x3f3f3f3f;
int n,ans;
int g[N][N],dis[N],vis[N];
void Prim(){
    int i;
    for(i=1;i<=n;i++){//初始化
        dis[i]=g[1][i];
        vis[i]=0;
    }
    dis[1]=0;
    vis[1]=1;
    int j,k,tmp;
    for(i=1;i<=n;i++){
        tmp=INF;
        for(j=1;j<=n;j++)
            if(!vis[j] && tmp>dis[j]){
                k=j;
                tmp=dis[j];
            }
        if(tmp==INF)
            break;
        vis[k]=1;
        ans+=dis[k];
        for(j=1;j<=n;j++)
            if(!vis[j] && dis[j]>g[k][j])
                dis[j]=g[k][j];
    }
}

int main()
{
    while(~scanf("%d",&n)){
        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
                scanf("%d",&g[i][j]);
        int q,a,b;
        scanf("%d",&q);
        while(q--){
            scanf("%d%d",&a,&b);
            g[a][b]=g[b][a]=0;//两条边的边权为0
        }
        ans=0;
        Prim();
        printf("%d\n",ans);
    }
    return 0;
}

发布了36 篇原创文章 · 获赞 10 · 访问量 1930

猜你喜欢

转载自blog.csdn.net/weixin_44003265/article/details/96561227