HDU 1102(Constructing Roads)(最小生成树之prim算法)

题目链接:

http://acm.hdu.edu.cn/showproblem.php?pid=1102

Constructing Roads

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 27178    Accepted Submission(s): 10340


Problem Description
There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected.

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.
 
Input
The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.
 
Output
You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.
 
Sample Input
3
0 990 692
990 0 179
692 179 0
1
1 2
 
Sample Output
179
 
Source
分析:
裸最小生成树
注意点:
自己到自己的距离初始化为无穷大
多组输入(这个题目没有说,但是需要才能ac)
存图的时候要多注意,要细心,不能存错了,尤其是下标
#include<bits/stdc++.h>
using namespace std;
#define INF 1000000
#define max_v 105
int g[max_v][max_v];//g[i][j] 表示i点到j点的距离
int n,sum;
void init()
{
    for(int i=0; i<n; i++)
        for(int j=0; j<n; j++)
            g[i][j]=INF;
}
void prim()
{
   // int close[n];//记录不在s中的点在s中的最近邻接点
    int lowcost[n];//记录不在s中的点到s的最短距离,即到最近邻接点的权值
    int used[n];//点在s中为1,否则为0
    for(int i=0; i<n; i++)
    {
        //初始化,s中只有一个点(0)
        lowcost[i]=g[0][i];//获取其他点到0点的距离,不相邻的点距离无穷大
      //  close[i]=0;//初始化所有点的最近邻接点都为0点
        used[i]=0;//初始化所有点都没有被访问过
    }
    used[0]=1;
    for(int i=1; i<n; i++)
    {
        //找点
        int j=0;
        for(int k=0; k<n; k++) //找到没有用过的且到s距离最小的点
        {
            if(!used[k]&&lowcost[k]<lowcost[j])
                j=k;
        }
       //  printf("%d %d %d\n",close[j]+1,j+1,lowcost[j]);
        sum+=lowcost[j];
        used[j]=1;//j点加入到s中
        //松弛
        for(int k=0; k<n; k++)
        {
            if(!used[k]&&g[j][k]<lowcost[k])
            {
                lowcost[k]=g[j][k];
             //   close[k]=j;
            }
        }
    }
}
int main()
{
    while(~scanf("%d",&n))
    {
        sum=0;
        init();
        for(int i=0; i<n; i++)
        {
            for(int j=0; j<n; j++)
            {
                int x;
                scanf("%d",&x);
                if(i==j)
                    continue;
                g[i][j]=x;
            }
        }
        int q;
        scanf("%d",&q);
        for(int i=0; i<q; i++)
        {
            int a,b;
            scanf("%d %d",&a,&b);
            g[a-1][b-1]=0;
            g[b-1][a-1]=0;
        }
        prim();
        printf("%d\n",sum);
    }
    return 0;
}
 

猜你喜欢

转载自www.cnblogs.com/yinbiao/p/9183794.html